点击打开链接题目链接
Cube Stacking
Time Limit: 2000MS | Memory Limit: 30000K | |
Total Submissions: 19046 | Accepted: 6633 | |
Case Time Limit: 1000MS |
Description
Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.
Write a program that can verify the results of the game.
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.
Write a program that can verify the results of the game.
Input
* Line 1: A single integer, P
* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.
Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.
Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Print the output from each of the count operations in the same order as the input file.
Sample Input
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
Sample Output
1 0 2
给出30000个箱子 M操作代表把含有a箱子的箱子堆放到含有箱子b的箱子堆上
c查询a下面有几个箱子
sum代表集合中箱子的总数
dep代表该点与祖先节点的距离
#include<stdio.h>
#include<string.h>
int dep[30030];
int father[30030];
int sum[30030];
void init()
{
for(int i=1;i<=30030;i++)
{
father[i]=i;
dep[i]=0;
sum[i]=1;
}
}
int find(int a)
{
if(a==father[a])
return a;
int t=father[a];
father[a]=find(father[a]);
dep[a]+=dep[t];
return father[a];
}
void add(int a,int b)
{
int x,y;
x=find(a);
y=find(b);
if(x!=y)
{
father[y]=x;
dep[y]=sum[x];
sum[x]+=sum[y];
}
}
int main()
{
int p;
char str[5];
int i,a,b;
while(scanf("%d",&p)!=EOF)
{
init();
while(p--)
{
scanf("%s",str);
if(str[0]=='M')
{
scanf("%d %d",&a,&b);
add(a,b);
}
else
{
scanf("%d",&a);
int fa=find(a);
printf("%d\n",sum[fa]-dep[a]-1);
}
}
}
}