HDU 1394 Minimum Inversion Number 线段树

点击打开链接题目链接

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11345    Accepted Submission(s): 6967


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

求一组数(可以将第一个数放到最后)的最小逆序对数

在插入每个数的同时查询(x[i]-n-1)的数出现过的个数然后更新

#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 5555
using namespace std;
int sum[MAXN<<2];
int x[MAXN];
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        return sum[rt];
    }
    int cnt=0;
    int mid=(l+r)>>1;
    if(L<=mid)
        cnt=query(L,R,l,mid,rt<<1);
    if(R>mid)
        cnt+=query(L,R,mid+1,r,rt<<1|1);
    return cnt;
}
void update(int q,int l,int r,int rt)
{
    if(l==r)
    {
        sum[rt]=1;
        return  ;
    }
    int mid=(l+r)>>1;
    if(q<=mid)
        update(q,l,mid,rt<<1);
    else
        update(q,mid+1,r,rt<<1|1);
    pushup(rt);
}
int main()
{
    int n,i,xxx,ans;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n<<2;i++)
        {
            sum[i]=0;
        }
        xxx=0;
        for(i=0;i<n;i++)
        {
            scanf("%d",&x[i]);
            xxx+=query(x[i],n-1,0,n-1,1);
        //    for(int j=1;j<=16;j++)
        //{
          //  printf("%d ",sum[j]);
        //}
        //puts("");
            //printf("1\n");
            update(x[i],0,n-1,1);
            //for(int j=1;j<=16;j++)
        //{
          //  printf("%d ",sum[j]);
        //}
        //puts("");
        }
        ans=xxx;
        for(i=0;i<n;i++)
        {
            xxx+=n-x[i]-x[i]-1;
            ans=min(ans,xxx);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值