模拟2:L1-8 估值一亿的AI核心代码 (20分)

在这里插入图片描述
以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

无论用户说什么,首先把对方说的话在一行中原样打印出来;
消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
把原文中所有大写英文字母变成小写,除了 I;
把原文中所有独立的 can you、could you 对应地换成 I can、I could—— 这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 I 和 me 换成 you;
把原文中所有的问号 ? 换成惊叹号 !;
在一行中输出替换后的句子作为 AI 的回答。
输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know

题解1:

#include<stdio.h>
#include<string.h>
const int maxn = 1e4 + 5;
char s[10004], s1[10004];
int t = 0;
///大写转换成小写
char f(char c)
{
    return (c >= 'A'&&c <= 'Z'&&c != 'I') ? c + 32 : c;
}
///是否属于字符
int check(char c)
{
    return (c >= 'A'&&c <= 'Z') || (c <= 'z'&&c >= 'a');
}
///是否属于数字
int checkNum(char c)
{
    return (c >= '0'&&c <= '9');
}
///字母或者数字
int check1(char s)
{
    return check(s) || checkNum(s);
}
///字符串判断
int ff(int x, char str[])
{
    int i, l = strlen(str);
    for (i = 0; i < l&&x < t; i++, x++)
        if (s1[x] != str[i]) return 0;
    return i == l ? 1 : 0;
}
///初步处理,大写转小写、符号转换、处理空格
void fun()
{
    t = 0;
    memset(s1, 0, sizeof(s1));
    int l = strlen(s);
    int i = 0;
    while (s[i] == ' '&&s[i] != '\0')
        i++;
    while (s[l - 1] == ' '&&l >= i)
        l--;
    int flag = 0;
    for (; i < l; i++)
    {
        if (s[i] == '?')
            s1[t++] = '!';
        else if (s[i] == ' ')
        {
            if (!flag)
            {
                if (check1(s[i + 1]))
                    s1[t++] = s[i];
            }
            else
            {
                if (check1(s[i + 1]))
                {
                    s1[t++] = s[i];
                }

            }

        }
        else
        {
            flag = check1(s[i]);
            s1[t++] = f(s[i]);
        }
    }
    s1[t] = 0;
}
int main()
{
    int n;
    scanf("%d", &n);
    getchar();
    while (n--)
    {
        gets(s);
        fun();
        printf("%s\nAI: ", s);
        for (int i = 0; i < t; i++)
        {
            ///‘I’的前面要么没有字符,要么不是数字也不是字母,后面同样的
            if (s1[i] == 'I' && (!i || !check1(s1[i - 1])) && !check1(s1[i + 1]))
                printf("you");
            else if ((!i || !check1(s1[i - 1])) && s1[i] == 'm'&&s1[i + 1] == 'e' && !check1(s1[i + 2]))
            {
                printf("you");
                i++;
            }
            else if ((!i || !check1(s1[i - 1])) && s1[i] == 'c'&&s1[i + 1] == 'a')
            {
                ///判断是否会出现“can youooo”此类情况
                if (ff(i, "can you") && !check1(s1[i + 7]))
                {
                    printf("I can");
                    ///此处不加7而是加6是因为,for循环内的i++,会加1
                    i += 6;
                }
                else
                    printf("%c", s1[i]);
            }
            else if ((!i || !check(s1[i - 1])) && s1[i] == 'c'&&s1[i + 1] == 'o')
            {
                if (ff(i, "could you") && !check1(s1[i + 9]))
                {
                    printf("I could");
                    i += 8;
                }
                else
                    printf("%c", s1[i]);
            }
            else
            {
                printf("%c", s1[i]);
            }

        }
        printf("\n");
    }
    return 0;
}

题解2:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    cin >> n;
    getchar();  // 吸收换行 
    string s;
    while(n--){
        string str[1005];
        int cnt=0;
        getline(cin,s);
        cout << s << endl << "AI:";
        for(int i=0;i<s.size();++i){
            if(isalnum(s[i])){
                if(s[i]!='I')
                    s[i]=tolower(s[i]);
            }
            else{
                s.insert(i," ");    //对每个非字母和数字之前加空格
                i++;
            }
            if(s[i]=='?')
                s[i]='!';
        }
        stringstream ss(s);        //主要依靠这个函数来取消单词之前的空格
        while(ss >> s){
            str[cnt++]=s;
        }
        if(!isalnum(str[0][0]))     		// 如果 第一个单词的第一个位置就是标点  那么要输出一个空格,题中要求 每个 AI 的回答前要加上 AI: 和一个空格。
            cout << " ";
        for(int i=0;i<cnt;++i){
            if(!isalnum(str[i][0])){         // 判断第一个字符是否是 标点,标点前面不要输出空格
                cout << str[i];
            }
            else if((str[i]=="can" || str[i]=="could") && str[i+1]=="you"){ // &&优先级大于|| ,所以要加括号 
                cout << " I " << str[i];
                i++;
            }
            else if(str[i]=="I" || str[i]=="me"){
                cout << " you";
            }
            else
                cout << " " << str[i];
        }
        cout << endl;
    }
}

题解3:
待更

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值