OpenJudge_P1481 Maximum sum(最大双子序列和)

55 篇文章 4 订阅
16 篇文章 0 订阅

总时间限制: 1000ms 内存限制: 65536kB
描述
Given a set of n integers: A={a1, a2,…, an}, we define a function d(A) as below:

这里写图片描述

Your task is to calculate d(A).
输入
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, …, an. (|ai| <= 10000).There is an empty line after each case.
输出
Print exactly one line for each test case. The line should contain the integer d(A).
样例输入
1

10
1 -1 2 2 3 -3 4 -4 5 -5
样例输出
13
提示
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.
来源
POJ Contest,Author:Mathematica@ZSU

第一眼看去就是初赛题
m计算没有初始化成INT_MIN,初始化成0,无限WA

#include<cstdio>
#include<cstring>
#include<climits>
#include<iostream>
using namespace std;
#define N 50005
int t,n,ans,temp,m;
int a[N],f1[N],f2[N];
int main(){
    scanf("%d",&t);
    while(t--){
        memset(f1,0,sizeof(f1));memset(f2,0,sizeof(f2));
        scanf("%d",&n);temp=0,m=ans=INT_MIN;
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        for(int i=1;i<=n;i++){
            temp+=a[i];if(temp>m) m=temp; 
            if(temp<0) temp=0;
            f1[i]=m;
        }
        temp=0,m=INT_MIN;
        for(int i=n;i>=1;i--){
            temp+=a[i];if(temp>m) m=temp; 
            if(temp<0) temp=0;
            f2[i]=m;
        }
        for(int i=1;i<n;i++){
            ans=max(ans,f1[i]+f2[i+1]);
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值