Flowers

I - Flowers
Crawling in process... Crawling failed Time Limit:1500MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u

Description

We saw the little game Marmot made for Mole's lunch. Now it's Marmot's dinner time and, as we all know, Marmot eats flowers. At every dinner he eats some red and white flowers. Therefore a dinner can be represented as a sequence of several flowers, some of them white and some of them red.

But, for a dinner to be tasty, there is a rule: Marmot wants to eat white flowers only in groups of size k.

Now Marmot wonders in how many ways he can eat between a and b flowers. As the number of ways could be very large, print it modulo 1000000007 (109 + 7).

Input

Input contains several test cases.

The first line contains two integers t and k (1 ≤ t, k ≤ 105), where t represents the number of test cases.

The next t lines contain two integers ai and bi (1 ≤ ai ≤ bi ≤ 105), describing the i-th test.

Output

Print t lines to the standard output. The i-th line should contain the number of ways in which Marmot can eat between ai and bi flowers at dinner modulo 1000000007 (109 + 7).

Sample Input

Input
3 2
1 3
2 3
4 4
Output
6
5
5

Sample Output

     
     
37
 

Hint

  • For K = 2 and length 1 Marmot can eat (R).
  • For K = 2 and length 2 Marmot can eat (RR) and (WW).
  • For K = 2 and length 3 Marmot can eat (RRR), (RWW) and (WWR).
  • For K = 2 and length 4 Marmot can eat, for example, (WWWW) or (RWWR), but for example he can't eat (WWWR).

/*
 dp[i]=(dp[i-1]+dp[i-k])%MOD;
 正确的考虑情况:
    LL tmp=(sum[r]-sum[l-1])%MOD;
    if(tmp<0){
        tmp+=MOD;
        tmp%=MOD;
    }
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef __int64 LL;
const int MOD= 1000000007 ;
const int maxn=100000+10;
LL  dp[maxn],sum[maxn];
LL  t,k,l,r;
int main(){
scanf("%I64d%I64d",&t,&k);
for(int i=0;i<k;i++){
    dp[i]=1;
}
for(int i=k;i<maxn;i++){
 dp[i]=(dp[i-1]+dp[i-k])%MOD;
}
for(int i=1;i<maxn;i++){
    sum[i]=(sum[i-1]+dp[i])%MOD;
}
while(t--){
    scanf("%I64d%I64d",&l,&r);
    LL tmp=(sum[r]-sum[l-1])%MOD;
    if(tmp<0){
        tmp+=MOD;
        tmp%=MOD;
    }
    printf("%I64d\n",tmp);
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值