Truck History

G - Truck History
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.
废话不多说,这道题最难得是难以看懂,题意提供,保证可过,题目是用7个字符串来形容一个类型的车子,从字符串开头到末尾有多少个不同的字母就代表着两辆型号的车的派生中的距离,所以便可以for(int k=0;k<7;k++){
                    if(trucks[i][k]!=trucks[j][k]){
                        cots++;
                    }

                }

来判断两个型号的车子之间的距离。

题目最终求的是让1/Q最大,那么Q又是所有车的距离,所以,我们要通过最小生成树,找到最小连接所有类型车辆的距离是多少就可以了。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn =2000+5;
char trucks[maxn][10];
int par[maxn];
int n,cnt,cots;
struct edge{
    int v,u,cost;
    bool operator<(const edge &a)const {
        return cost<a.cost;
    }
}es[maxn*maxn];

void init(){
    for(int i=0;i<maxn;i++){
        par[i]=i;
    }
}

int find(int x){
    return par[x]==x?x:par[x]=find(par[x]);
}

bool same(int x,int y){
    return find(x)==find(y);
}

void unite(int x,int y){
    x=find(x);
    y=find(y);
    par[x]=y;
}

void getResult(){
    sort(es,es+cnt);
    init();
    long long res=0;
    for(int i=0;i<cnt;i++){
        edge e=es[i];
        if(!same(e.u,e.v)){
            res+=e.cost;
            unite(e.u,e.v);
        }
    }
    printf("The highest possible quality is 1/%lld.\n",res);
}
int main() {
    while(~scanf("%d",&n),n){
        cnt=0;
        for(int i=0;i<n;i++){
            scanf("%s",trucks[i]);
        }
        for(int i=0;i<n;i++){
            for(int j=i+1;j<n;j++){
                cots=0;
                for(int k=0;k<7;k++){
                    if(trucks[i][k]!=trucks[j][k]){
                        cots++;
                    }
                }
                es[cnt].v=i,es[cnt].u=j,es[cnt++].cost=cots;
            }
        }
        getResult();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值