钱币兑换问题

E - 钱币兑换问题
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

在一个国家仅有1分,2分,3分硬币,将钱N兑换成硬币有很多种兑法。请你编程序计算出共有多少种兑法。
 

Input

每行只有一个正整数N,N小于32768。
 

Output

对应每个输入,输出兑换方法数。
 

Sample Input

     
     
2934 12553
 

Sample Output

     
     
718831 13137761
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=32768+5;
int n;
int dp[maxn][5];
void init() {
    memset(dp,0,sizeof(dp));
    dp[1][1]=1;
    dp[1][2]=1;
    dp[1][3]=1;
    dp[2][1]=1;
    dp[2][2]=2;
    dp[2][3]=2;
    dp[3][1]=1;
    dp[3][2]=2;
    dp[3][3]=3;
    for(int i=4;i<maxn;i++)
    {
        for(int j=1;j<=3;j++)
        {
            if(j==1)dp[i][j]=1;
            else dp[i][j]=dp[i-j][j]+dp[i][j-1];
        }
    }
}
int main() {
    init();
    while(~scanf("%d",&n)) {
        printf("%d\n",dp[n][3]);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值