POJ - 3321 Apple Tree (线段树 + 建树 + 思维转换)

POJ - 3321
Time Limit: 2000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

 Status

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2
/*
Author: 2486
Memory: 10004 KB		Time: 766 MS
Language: G++		Result: Accepted
*/
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
#define lson rt << 1, l, mid
#define rson rt << 1|1, mid + 1, r
#define root 1, 1, N
const int MAXN = 2e5 + 5;
int sum[MAXN << 2], LU[MAXN], RU[MAXN], N, M, A, B, tot, K;
char op[10];

/***********加边模板***************/
int Head[MAXN], Next[MAXN], rear;
struct edge {
    int u,v;
} es[MAXN];

void Edge_Init() {
    rear = 0;
    memset(Head, -1, sizeof(Head));
}

void Edge_Add(int u,int v) {
    es[rear].u = u;
    es[rear].v = v;
    Next[rear] = Head[u];
    Head[u] = rear ++;
}

void DFS(int to, int from) {
    LU[to] = ++ tot;//用来标记属于它的子树的序列
    for(int i = Head[to] ; ~ i; i = Next[i]) {
        int v = es[i].v;
        if(v == from) continue;
        DFS(v, to);
    }
    RU[to] = tot;
}
/**********************************/



void pushup(int rt) {
    sum[rt] = sum[rt << 1] + sum[rt << 1|1];
}


void build(int rt, int l, int r) {
    if(l == r) {
        sum[rt] = 1;
        return ;
    }
    int mid = (l + r) >> 1;
    build(lson);
    build(rson);
    pushup(rt);
}

void update(int p,int rt,int l, int r) {
    if(l == r) {
        sum[rt] ^= 1;
        return;
    }
    int mid = (l + r) >> 1;
    if(p <= mid) update(p, lson);
    else update(p, rson);
    pushup(rt);
}

int query(int L, int R,int rt, int l, int r) {
    if(L <= l && r <= R) {
        return sum[rt];
    }
    int mid = (l + r) >> 1;
    int res = 0;
    if(L <= mid) res += query(L, R, lson);
    if(R > mid) res += query(L, R, rson);
    return res;
}

int main() {
    //freopen("D://imput.txt","r",stdin);
    while(~ scanf("%d", &N)) {
        tot = 0;
        build(root);
        Edge_Init();
        for(int i = 1; i < N ; i ++) {
            scanf("%d%d", &A, &B);
            Edge_Add(A, B);
            Edge_Add(B, A);
        }
        DFS(1, -1);
        scanf("%d", &M);
        while(M --) {
            scanf("%s %d", op, &K);
            if(op[0] == 'C') {
                update(LU[K],root);
            } else {
                printf("%d\n", query(LU[K],RU[K],root));
            }
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值