HDU 1028 Ignatius and the Princess III(母函数 或者 整数划分的DP动态规划)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15710    Accepted Submission(s): 11080


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
母函数知识点代码中有讲解
/*
(1+x+x^2+x^3+……)*指数相差1
(1+x^1*2+x^2*2+x^3*2+……)*指数相差2
(1+x^1*3+x^2*3+x^3*3+……)*指数相差3
(1+x^1*4+x^2*4+x^3*4+……)*指数相差4
(1+x^1*5+x^2*5+x^3*5+……)*指数相差5
(1+x^1*n)
n的拆分方法个数为最终结果中x^n的系数*/


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 120 + 5;
int s[MAXN], t[MAXN];
int main() {
    int n,i,j,k;
    while(~scanf("%d",&n)) {
        for(i = 0; i <= n; i ++) {
            s[i] = 1;//表示第一个式子初始的系数
            t[i] = 0;//临时数组
        }
        for(i = 2; i <= n; i ++) { //第i个(1+x^i+x^2*i+x^3*i+...)
            for(j = 0; j <= n; j ++) { //(1+x+x^2+x^3+...)中的第j项
                for(k = 0; k * i + j <= n; k ++) {
                    //(k*i)是第i个(1+x^i+x^2*i+x^3*i+...)中的第k项,用(1+x+x^2+x^3+...)中的第j项乘
                    //第i个(1+x^i+x^2*i+x^3*i+...)中的第k项所得的x的幂即为(k*i+j)
                    t[k * i + j] += s[j];//最后能够形成x^(k*i+j)的系数 + s[j]即为乘以该式所形成的系数
                }
            }
            for(j = 0; j <= n; j ++) {
                s[j] = t[j];//更新第1行式子的系数
                t[j] = 0;
            }
        }
        printf("%d\n", s[n]);
    }
    return 0;
}



#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long LL;
int dp[125][125],n;
//dp[i][j]表示将i划分为不大于j的最大划分数
int main() {
    while(~scanf("%d",&n)) {
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= n; i ++) {
            for(int j = 1; j <= n; j ++) {
                if(i > j) {//取出一个j
                    dp[i][j] = dp[i - j][j] + dp[i][j - 1];
                } else if(i == j) {
                    dp[i][j] = dp[i][j - 1] + 1;
                } else {
                    dp[i][j] = dp[i][i];
                }
            }
        }
        printf("%d\n",dp[n][n]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值