POJ - 3185 The Water Bowls (反转)

The Water Bowls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5852 Accepted: 2296

Description

The cows have a line of 20 water bowls from which they drink. The bowls can be either right-side-up (properly oriented to serve refreshing cool water) or upside-down (a position which holds no water). They want all 20 water bowls to be right-side-up and thus use their wide snouts to flip bowls. 

Their snouts, though, are so wide that they flip not only one bowl but also the bowls on either side of that bowl (a total of three or -- in the case of either end bowl -- two bowls). 

Given the initial state of the bowls (1=undrinkable, 0=drinkable -- it even looks like a bowl), what is the minimum number of bowl flips necessary to turn all the bowls right-side-up?

Input

Line 1: A single line with 20 space-separated integers

Output

Line 1: The minimum number of bowl flips necessary to flip all the bowls right-side-up (i.e., to 0). For the inputs given, it will always be possible to find some combination of flips that will manipulate the bowls to 20 0's.

Sample Input

0 0 1 1 1 0 0 1 1 0 1 1 0 0 0 0 0 0 0 0

Sample Output

3

Hint

Explanation of the sample: 

Flip bowls 4, 9, and 11 to make them all drinkable: 
0 0 1 1 1 0 0 1 1 0 1 1 0 0 0 0 0 0 0 0 [initial state] 
0 0 0 0 0 0 0 1 1 0 1 1 0 0 0 0 0 0 0 0 [after flipping bowl 4] 
0 0 0 0 0 0 0 0 0 1 1 1 0 0 0 0 0 0 0 0 [after flipping bowl 9] 
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 [after flipping bowl 11]

对于我们自己增加的前置元素,要考虑它所有可能的值
然后就是用反转了
/*?????*/

#include <map>
#include <set>
#include <cmath>
#include <ctime>
#include <queue>
#include <vector>
#include <cctype>
#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <cstdlib>
#include <typeinfo>
#include <iostream>
#include <algorithm>
#include <functional>

using namespace std;

#define pb push_back
#define mp make_pair
#define mem(a, x) memset(a, x, sizeof(a))
#define copy(a, b) memcpy(a, b, sizeof(a))
#define lson rt << 1, l, mid
#define rson rt << 1|1, mid + 1, r
#define FIN freopen("input.txt", "r", stdin)
#define FOUT freopen("output.txt", "w", stdout)

typedef long long LL;
typedef pair<int, int > PII;
typedef pair<int,string> PIS;
typedef unsigned long long uLL;

template<typename T>
void print(T* p, T* q, string Gap = " ", bool flag = false) {
	int d = p < q ? 1 : -1;
	while(p != q) {
		if(flag) cout << Gap[0] << *p << Gap[1];
		else cout << *p;
		p += d;
		if(p != q && !flag) cout << Gap;
	}
	cout << endl;
}

template<typename T>
void print(const T &a, string bes = "") {
	int len = bes.length();
	if(len >= 2)cout << bes[0] << a << bes[1] << endl;
	else cout << a << endl;
}

void IO_Init() {
	ios::sync_with_stdio(false);
}

LL LLabs(LL a) {
	return a > 0 ? a : -a;
}

const double PI = 3.1415926535898;
const double eps = 1e-10;
const int MAXM = 1e4 + 5;
const int MAXN = 1e5 + 5;
const LL INF = 0x3f3f3f3f;

/*?????*/

int dir[MAXN];
int f[MAXN];

int calc(int x) {
	memset(f, 0, sizeof(f));
	int res = 0, sum = 0;
	dir[0] = x;
	for(int i = 0; i < 20; i ++) {
		if((dir[i] + sum) & 1) {
			res ++;
			f[i] = 1;
		}
		sum += f[i];
		if(i - 3 + 1 >= 0) {
			sum -= f[i - 3 + 1];
		}
	}
    if((dir[20] + sum) & 1){
        return INF;
    }
	return res;
}

void solve() {
	printf("%d\n", min(calc(0), calc(1)));
}

int main() {
	//FIN;
	while(~scanf("%d", &dir[1])) {
		for(int i = 2; i <= 20; i ++) {
			scanf("%d", &dir[i]);
		}
		solve();
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值