POJ - 1990 MooFest (树状数组)

MooFest
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6902 Accepted: 3095

Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing. 

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)). 

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume. 

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location. 

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows. 

Sample Input

4
3 1
2 5
2 6
4 3

Sample Output

57
 
题意:一群牛参加完牛的节日后都有了不同程度的耳聋,第i头牛听见别人的讲话,别人的音量必须大于v[i],当两头牛i,j交流的时候,交流的最小声音为max{v[i],v[j]}*他们之间的距离。现在有n头牛,求他们的声音之和
 
用两个树状数组分别标记小于V[i]的个数,和小于V[i]的位置之和,然后在分别求一次位置小于X[i]的值和位置大于X[i]的和。
 
/*头文件模板*/

#include <map>
#include <set>
#include <cmath>
#include <ctime>
#include <queue>
#include <stack>
#include <vector>
#include <cctype>
#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <cstdlib>
#include <iomanip>
#include <typeinfo>
#include <iostream>
#include <algorithm>
#include <functional>

using namespace std;

#define pb push_back
#define mp make_pair
#define mem(a, x) memset(a, x, sizeof(a))
#define copy(a, b) memcpy(a, b, sizeof(a))
#define lson rt << 1, l, mid
#define rson rt << 1|1, mid + 1, r
#define FIN freopen("input.txt", "r", stdin)
#define FOUT freopen("output.txt", "w", stdout)

typedef long long LL;
typedef pair<int, int > PII;
typedef pair<int, string> PIS;
typedef pair<LL, LL>PLL;
typedef unsigned long long uLL;

template<typename T>
void print (T* p, T* q, string Gap = " ", bool flag = false) {
	int d = p < q ? 1 : -1;
	while (p != q) {
		if (flag) cout << Gap[0] << *p << Gap[1];
		else cout << *p;
		p += d;
		if (p != q && !flag) cout << Gap;
	}
	cout << endl;
}

template<typename T>
void print (const T &a, string bes = "") {
	int len = bes.length();
	if (len >= 2) cout << bes[0] << a << bes[1] << endl;
	else cout << a << endl;
}

template<typename T>
void debug (T* p, T* q, string Gap = " ", bool flag = false) {
#ifndef ONLINE_JUDGE
	int d = p < q ? 1 : -1;
	cout << "Debug out : ";
	while (p != q) {
		if (flag) cout << Gap[0] << *p << Gap[1];
		else cout << *p;
		p += d;
		if (p != q && !flag) cout << Gap;
	}
	cout << endl;
#endif
}

template<typename T>
void debug (const T &a, string bes = "") {
#ifndef ONLINE_JUDGE
	int len = bes.length();
	cout << "Debug out : ";
	if (len >= 2) cout << bes[0] << a << bes[1] << endl;
	else cout << a << endl;
#endif
}

void IO_Init() {
	ios::sync_with_stdio (false);
}

LL LLabs (const LL a) {
	return a >= 0 ? a : -a;
}

const double PI = 3.1415926535898;
const double eps = 1e-10;
const int MAXM = 1e5 + 5;
const int MAXN = 2e4 + 5;
const int INF = 0x3f3f3f3f;

/*头文件模板*/



LL bits1[MAXN], bits2[MAXN];
int V[MAXN], X[MAXN];

struct o {
	int v, x;
	bool operator < (const o &p) const {
		return x < p.x;
	}
} O[MAXN];

void add(LL *C, int p, int v, int n) {
	while(p <= n) {
		C[p] += (LL)v;
		p += p & -p;
	}
}

LL sum(LL *C,int p) {
	LL ret = 0;
	while(p > 0) {
		ret += C[p];
		p -= p & -p;
	}
	return ret;
}

void init() {
	mem(bits1, 0);
	mem(bits2, 0);
}
int main() {
#ifndef ONLINE_JUDGE
	//FIN;
	//FOUT;
#endif
	IO_Init();
	int n;
	while(~scanf("%d", &n)) {
		for(int i = 0; i < n; i ++) {
			scanf("%d%d", &O[i].v, &O[i].x);
		}
		sort(O, O + n);
		LL ret = 0, s = 0;
		init();
		for(int i = 0; i < n; i ++) {
		    LL l = sum(bits1, O[i].v);//<=O[i].v的个数
		    LL r = sum(bits2, O[i].v);//<=O[i].v的位置之和
		    ret += (l * O[i].x - r) * O[i].v;//求出位置小于O[i].x的价值绝对值之和
			add(bits1, O[i].v, 1, MAXN - 1);
			add(bits2, O[i].v, O[i].x, MAXN - 1);
		}
		init();
		for(int i = n - 1;i >= 0;i --){
            LL l = sum(bits1, O[i].v - 1);//>O[i].v的个数
            LL r = sum(bits2, O[i].v - 1);//>O[i].v的位置之和
            ret += (r - l * O[i].x) * O[i].v;
            add(bits1, O[i].v, 1, MAXN - 1);
			add(bits2, O[i].v, O[i].x, MAXN - 1);
		}
		printf("%lld\n", ret);
	}

	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值