pat 1113. Integer Set Partition

Given a set of N (> 1) positive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1 and n2 numbers, respectively. Let S1 and S2 denote the sums of all the numbers in A1 and A2, respectively. You are supposed to make the partition so that |n1 - n2| is minimized first, and then |S1 - S2| is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2 <= N <= 10^5), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 231.

Output Specification:

For each case, print in a line two numbers: |n1 - n2| and |S1 - S2|, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

思路:排序,奇偶数单独处理就行了。PS:最新的这套甲级题真心水,就第一题出的可以点

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100005;
int n;
int a[maxn];
int main(){
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&n)==1){
        int s1=0,s2=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            s2+=a[i];
        }
        sort(a,a+n);
        printf("%d",n%2);
        int m=n/2;
        for(int i=0;i<m;i++){
            s1+=a[i];
        }
        s2-=s1;
        printf(" %d\n",s2-s1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
`list.partition()` 和 `set.partition()` 是两种不同的方法,用于不同的数据类型。 `list.partition()` 是 Python 内置的列表方法,它接受一个谓词函数作为参数,并将列表拆分为两个部分:满足谓词函数的元素和不满足谓词函数的元素。它返回一个元组,其中第一个元素是满足谓词函数的元素列表,第二个元素是不满足谓词函数的元素列表,第三个元素是剩余的元素列表(如果有的话)。 例如,假设我们有一个整数列表 `[1, 2, 3, 4, 5, 6]`,我们想要将它们分为奇数和偶数两部分,可以使用 `list.partition()` 方法: ```python nums = [1, 2, 3, 4, 5, 6] odd, even, rest = nums.partition(lambda x: x % 2 != 0) print(odd) # [1, 3, 5] print(even) # [2, 4, 6] print(rest) # [] ``` `set.partition()` 并不是 Python 内置的方法,因为 `set` 类型本身就不保留项目的顺序。因此,`set.partition()` 不是一个有效的方法。 不过,我们可以通过手动编写代码来模拟 `set.partition()` 的行为。例如,假设我们有一个字符串集合 `{'apple', 'banana', 'cherry', 'date'}`,我们想要将它们分为两部分:以字母 'a' 开头的字符串和不以字母 'a' 开头的字符串。我们可以使用以下代码: ```python strings = {'apple', 'banana', 'cherry', 'date'} a_start = set(filter(lambda s: s.startswith('a'), strings)) not_a_start = strings - a_start print(a_start) # {'apple'} print(not_a_start) # {'banana', 'cherry', 'date'} ``` 这段代码使用了 Python 内置的 `filter()` 函数和 `set` 类型的差集运算。它首先使用 `filter()` 函数找到以字母 'a' 开头的字符串,然后使用差集运算将它们从原始集合中移除,得到不以字母 'a' 开头的字符串集合。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值