杭电1143



/*
Problem Description
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.




Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30.


Output
For each test case, output one integer number giving the number of possible tilings.


Sample Input
2
8
12
-1


Sample Output
3
153
2131

//当n为奇数时,面积也是奇数,所以不可能用偶数的面积填满,即n为奇数时输出为0
可以看到图形的高都是3,所以要么在最上面放一层
或者在最下面放一层,让高变成2,而让图不可分
剩下的高为2的部分,必须在两头各竖着放一个
要不图形就可以分成两个小图形了
这样就不满足我们递推的思路了
这样其实可以得到一个规律,只有k为2时g(k)是3
其余的情况,g(k)都是2
这样我们就可以简单的写出递推式:
f(n)=3*f(n-2)+2*f(n-4)+.....+2*f(2)
同理
f(n-2)=3*f(n-4)+2*f(n-6)+.....+2*f(2)
f(n)-4*f(n-2)=-f(n-4);
所以最终的递推式就是
f(n)=4*f(n-2)-f(n-4)
*/

#include<stdio.h>
#include<string.h>
int main()
{
    int i, j, n, m, f, s, a[1000];
    while(scanf("%d", &n)!=EOF && n!=-1)
    {
        memset(a, 0, sizeof(a));
        a[0] = 1;
        a[2] = 3;
        for(i=4; i<=n; i+=2)
        {
            a[i] = 4*a[i-2]-a[i-4];
        }
        printf("%d\n", a[n]);
    }
    return 0;
}

/*
Problem Description
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.




Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30.


Output
For each test case, output one integer number giving the number of possible tilings.


Sample Input
2
8
12
-1


Sample Output
3
153
2131

//当n为奇数时,面积也是奇数,所以不可能用偶数的面积填满,即n为奇数时输出为0
可以看到图形的高都是3,所以要么在最上面放一层
或者在最下面放一层,让高变成2,而让图不可分
剩下的高为2的部分,必须在两头各竖着放一个
要不图形就可以分成两个小图形了
这样就不满足我们递推的思路了
这样其实可以得到一个规律,只有k为2时g(k)是3
其余的情况,g(k)都是2
这样我们就可以简单的写出递推式:
f(n)=3*f(n-2)+2*f(n-4)+.....+2*f(2)
同理
f(n-2)=3*f(n-4)+2*f(n-6)+.....+2*f(2)
f(n)-4*f(n-2)=-f(n-4);
所以最终的递推式就是
f(n)=4*f(n-2)-f(n-4)
*/

#include<stdio.h>
#include<string.h>
int main()
{
    int i, j, n, m, f, s, a[1000];
    while(scanf("%d", &n)!=EOF && n!=-1)
    {
        memset(a, 0, sizeof(a));
        a[0] = 1;
        a[2] = 3;
        for(i=4; i<=n; i+=2)
        {
            a[i] = 4*a[i-2]-a[i-4];
        }
        printf("%d\n", a[n]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值