大整数的相加和大小判断

问题

1065 A+B and C (64bit) (20 分)
Given three integers A, B and C in [−2
63
,2
63
], you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
结尾无空行
Sample Output:
Case #1: false
Case #2: true
Case #3: false
结尾无空行
Thanks to Jiwen Lin for amending the test data.

思路

根据溢出的类型判断相加的结果是否大于给定的数。两个正数相加,结果小于0,发生正溢出。两个负数相加,结果大于等于0,发生负溢出。

代码

#include<bits/stdc++.h>
using namespace std;
long long A,B,C;

int main(){
    int tcase;
    long long temp;
    cin>>tcase;
    for (int i = 1; i <= tcase; ++i) {
        scanf("%lld%lld%lld",&A,&B,&C);
        temp = A+B;
        if(A>0 && B>0 && temp<0){
            cout<<"Case #"<<i<<": true"<<endl;
        }
        else if(A<0 && B<0 && temp >= 0){
            cout<<"Case #"<<i<<": false"<<endl;
        }
        else if(temp>C){
            cout<<"Case #"<<i<<": true"<<endl;
        }
        else
            cout<<"Case #"<<i<<": false"<<endl;
    }

    return 0;
}

总结

输入的时候不能用cin,因为cin不支持long long的输入,而应该用scanf

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值