字符串的匹配

问题

1050 String Subtraction (20 分)
Given two strings S
1

and S
2

, S=S
1

−S
2

is defined to be the remaining string after taking all the characters in S
2

from S
1

. Your task is simply to calculate S
1

−S
2

for any given strings. However, it might not be that simple to do it fast.

Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S
1

and S
2

, respectively. The string lengths of both strings are no more than 10
4
. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:
For each test case, print S
1

−S
2

in one line.

Sample Input:
They are students.
aeiou
结尾无空行
Sample Output:
Thy r stdnts.

代码

#include <iostream>
using namespace std;

int main(){
    char S1[10010],S2[10010];
    scanf("%[^\n]",S1);
    getchar();
    scanf("%[^\n]",S2);
    string ans="";
    string SS1 = S1,SS2 = S2;
    for (int i = 0; i < SS1.length(); ++i) {
        if(SS2.find(SS1[i]) == string::npos){
            ans = ans+SS1[i];
        }
    }
    cout<<ans<<endl;
    return 0;
}

总结

特别要注意:
输入带空格的字符串要使用char[]和scanf。并且要用getchar吸收每个字符串结尾的换行符。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值