寻找两个序列的中位数

这篇博客介绍了PAT甲级考试中的一道编程题,题目要求找到两个递增序列的中位数。作者分享了一个简洁的解决方案,通过将两个序列合并并排序,然后直接输出排序后序列的中间元素。尽管官方通过率低,但作者用这种方法快速通过了所有测试用例,对此感到惊讶。
摘要由CSDN通过智能技术生成

问题

1029 Median (25 分)
Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10
5
) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:
For each test case you should output the median of the two given sequences in a line.

Sample Input:
4 11 12 13 14
5 9 10 15 16 17
结尾无空行
Sample Output:
13

思路

只用一个可变长数组接收这两个序列,然后从小到大排序,最后输出下标为(n+m-1)/2的元素就是中位数。

代码

#include<bits/stdc++.h>
using namespace std;

int main(){
    int n,m,temp;
    vector<long long> seq;
    cin>>n;
    for (int i = 0; i < n; ++i) {
        cin>>temp;
        seq.push_back(temp);
    }
    cin>>m;
    for (int j = 0; j < m; ++j) {
        cin>>temp;
        seq.push_back(temp);
    }

    sort(seq.begin(),seq.end());
    cout<<seq[(n+m-1)/2];
    return 0;
}

总结

这道题我大牙都惊掉了,我看到pat官网的通过率为0.17,说明这题应该是很有难度的。很多大佬的博客包括一些参考书上的做法都是双指针。我用上面的方法3分钟就ac了。真的一脸懵逼,甚至一度怀疑是因为我恰好把所有用例都骗过去了?

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值