在字符串中特定字串的数量

问题

1093 Count PAT’s (25 分)
The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10
5
characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT
结尾无空行
Sample Output:
2

思路

统计每个A字符左边P的数量,右边T的数量。分别存在数组P[]和T[]中,最后遍历整个字符串,找A,所有A的P[j]*T[j]之和就是答案。

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 100010;
int main(){
    string str;
    cin>>str;
    int P[maxn],T[maxn],Pcount = 0,Tcount = 0;
    long long ans=0;
    for (int i = 0; i < str.length(); ++i) {
        if(i==0){
            if(str[i]=='P')
                Pcount++;
            P[i] = 0;
            continue;
        }
        if(str[i] == 'P'){
            P[i] = Pcount++;;
        }
        else{
            P[i] = Pcount;
        }
    }
    for (int i = str.length()-1; i >= 0; --i) {
        if(i==str.length()-1){
            if(str[i]=='T')
                Tcount++;
            T[i] = 0;
            continue;
        }
        if(str[i] == 'T'){
            T[i] = Tcount++;;
        }
        else{
            T[i] = Tcount;
        }
    }
    for (int j = 0; j < str.length(); ++j) {
        if(str[j]=='A'){
            ans = ans+P[j]*T[j];
        }
    }
    cout<<ans%1000000007;
    return 0;
}

总结

特别要注意,结果对1000000007取余,所以ans变量要设置成long long型。算法中使用了三次for单层循环,时间复杂度在O(n)数量级。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值