分数相加问题

问题

1081 Rational Sum (20 分)
Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:
Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 … where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:
For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
结尾无空行
Sample Output 1:
3 1/3
结尾无空行
Sample Input 2:
2
4/3 2/3
结尾无空行
Sample Output 2:
2
结尾无空行
Sample Input 3:
3
1/3 -1/6 1/8
结尾无空行
Sample Output 3:
7/24

思路

结构体来存储分数,分子,分母。

代码

#include<bits/stdc++.h>
using namespace std;

struct fraction{
    int up;
    int down;
};
queue<fraction> f;

int gcd(int a,int b){
    if(b==0)return a;
    else return gcd(b,a%b);
}
int main(){
    int n,up,down;
    cin>>n;
    for (int i = 0; i < n; ++i) {
        scanf("%d/%d",&up,&down);
        fraction s;
        s.up = up;
        s.down = down;
        f.push(s);
    }
    fraction ans;
    while (f.size()>1){
        fraction p = f.front();
        f.pop();
        fraction q = f.front();
        f.pop();
        ans.up = p.up*q.down+q.up*p.down;
        ans.down = p.down*q.down;
        if(ans.down<0){
            ans.up = -ans.up;
            ans.down = -ans.down;
        }
        if(ans.up==0){
            ans.down = 1;
        }else{
            int d = gcd(abs(ans.up),abs(ans.down));
            ans.up = ans.up/d;
            ans.down = ans.down/d;
        }
        f.push(ans);
    }

    if(ans.up%ans.down==0)
        printf("%d\n",ans.up/ans.down);
    else if(ans.up>ans.down)
        printf("%d %d/%d",ans.up/ans.down,ans.up%ans.down,ans.down);
    else
        printf("%d/%d",ans.up,ans.down);

    return 0;
}

总结

记得分数三个步骤:
1.分子为0将分母置为1.
2.分母为负数,则然分子分母同取相反数。
3.寻找分子分母绝对值的最大公约数,用分子分母同除于这个数进行化简。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值