PAT-A1076题解


title: PAT A1076题解
date: 2019-04-17 18:36:31
tags:

1076 Forwards on Weibo (30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i]users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题解:

题目给出了N个使用者的数量和间接发布者的级数L,使用者的序号是从1到N的。下面N行为M[i]个间接发布序号为i的使用者的数量,紧跟M[i]个间接发布者的序号。最后一行为数量K,紧跟K个需要查询的使用者的序号。

看到level,直接想到BFS。因此,将样本数据输入,用BFS搜索一个节点在级数L之内的节点数。

代码如下:

#include <cstdio>
#include <iostream>
#include <vector>
#include <queue>
#include <cstring>

using namespace std;

vector<int> G[1001];
int visit[1001];
int N, L;

int BFS(int v)
{
	memset(visit, 0, sizeof(visit));
	visit[v] = 1;
	queue<int> q;
	int temp;
	int last = v;
	int level = 0;
	int tail;
	int count = 0;
	q.push(v);
	while(!q.empty())
	{
		temp = q.front();
		q.pop();
		
		for(int i = 0; i < G[temp].size(); i++)
		{
			if(!visit[G[temp][i]])
			{
				visit[G[temp][i]] = 1;
				q.push(G[temp][i]); 
				count++;
				tail = G[temp][i];
			}
		}
		
		
		if(temp == last)
		{
			level++;
			last = tail;
		}
		
		if(level == L)
			break;
		
	}
	return count;
}
int main()
{
	cin >> N >> L;
	int M;
	int m; 
	for(int i = 1; i <= N; i++)
	{
		cin >> M;
		for(int j = 0; j < M; j++)
		{
			cin >> m;
			G[m].push_back(i); 
		}
	}
	
	int K;
	int k;
	cin >> K;
	for(int i = 0; i < K; i++)
	{
		cin >> k;
		cout << BFS(k) << endl; 
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值