也是比较简单的递推问题,注意int型的数据会在47左右的时候溢出即可
Problem Description
有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。
Input
输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0 < a < b < 50)。
Output
对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。
Sample Input
2
1 2
3 6
Sample Output
1
3
AC代码:
#include <iostream>
#include <string>
#include <vector>
#include <cctype>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
long long arr[50]; //注意int类型的数据会溢出
int main()
{
int n;
cin >> n;
arr[0] = 0; arr[1] = 1;
for (auto i = 2; i < 50; i++)
{
arr[i] = arr[i - 1] + arr[i - 2];
}
int a, b;
while (n --)
{
cin >> a >> b;
cout << arr[b - a + 1] << endl;
}
return 0;
}