超级楼梯

简单的递推问题

Problem Description
有一楼梯共M级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第M级,共有多少种走法?

Input
输入数据首先包含一个整数N,表示测试实例的个数,然后是N行数据,每行包含一个整数M(1<=M<=40),表示楼梯的级数。

Output
对于每个测试实例,请输出不同走法的数量

Sample Input
2
2
3

Sample Output
1
2

AC代码:

#include <iostream>
#include <string>
#include <vector>
#include <cctype>
#include <cmath>
#include <cstring>
#include <algorithm>

using namespace std;
long long arr[50];
int main()
{
	int n;
	cin >> n;
	arr[1] = 1; arr[2] = 1;
	for (auto i = 3; i <= 40; i++)
	{
		arr[i] = arr[i - 1] + arr[i - 2];
	}
	int a;
	while (n --)
	{
		cin >> a;
		cout << arr[a] << endl;
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值