为了过题写的代码…很不优雅。
注意coefficient为0的最后要去掉。
题目描述
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
解题代码
#include "stdio.h"
#include "stdlib.h"
int main()
{
int e1[10], e2[10], e[10];
float c1[10], c2[10], c[10];
int k1, k2, k=0, pk;
int i, j, flag, etemp;
float ctemp;
scanf("%d", &k1);
for (i = 0; i < k1; i++) {
scanf("%d %f", &e1[i], &c1[i]);
flag = 0;
for (j = 0; j < k; j++) {
if (e[j] == e1[i]) {
c[j] = c[j] + c1[i];
flag = 1;
break;
}
}
if (!flag) {
e[k] = e1[i];
c[k] = c1[i];
k++;
}
}
scanf("%d", &k2);
for (i = 0; i < k2; i++) {
scanf("%d %f", &e2[i], &c2[i]);
flag = 0;
for (j = 0; j < k; j++) {
if (e[j] == e2[i]) {
c[j] = c[j] + c2[i];
flag = 1;
break;
}
}
if(!flag) {
e[k] = e2[i];
c[k] = c2[i];
k++;
}
}
for (j = 0; j < k - 1; j++)
for (i = 0; i < k - 1 - j; i++)
{
if (e[i] < e[i + 1])
{
etemp = e[i];
e[i] = e[i + 1];
e[i + 1] = etemp;
ctemp = c[i];
c[i] = c[i + 1];
c[i + 1] = ctemp;
}
}
pk = k;
for (i = 0; i < k; i++) {
if (c[i] == 0)
pk--;
}
printf("%d", pk);
for (i = 0; i < k; i++) {
if(c[i]!=0)
printf(" %d %.1f", e[i], c[i]);
}
return 0;
}