HDU_ACM_A+B for Input-Output Practice (III)

<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">问题描述:</span>
Problem Description
Your task is to Calculate a + b.
问题描述:
你的任务是计算a+b 

Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
 输入:
输入包含多个测试用例。每个测试用例包含一对整数a和b,每行有一对整数。0 0代表结束输入同时也代表测试用例的结束
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
 输出:
每行输入的一对整数a  b应该对应有a+b的和作为输出,每一行的输入对应有一行的输出
Sample Input
输入示例:
1 5
10 20
0 0
 
Sample Output
输出示例:
6
30


#include "stdio.h"
int main()
{
<span style="white-space:pre">	</span>int a,b;
<span style="white-space:pre">	</span>while(scanf("%d%d",&a,&b)!=EOF)
<span style="white-space:pre">	</span>{
<span style="white-space:pre">		</span>if(a==0&&b==0){
<span style="white-space:pre">		</span>return 0;
<span style="white-space:pre">		</span>}
<span style="white-space:pre">		</span>else{
<span style="white-space:pre">		</span>printf("%d\n",a+b);
<span style="white-space:pre">		</span>}
<span style="white-space:pre">	</span>}
<span style="white-space:pre">	</span>return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值