POJ1837 DP题
题目一开始看了N久…意思大概是有一个天平,左边臂长是-15到0,右边臂长是0到15,给你c个挂钩,g个砝码,每一个砝码重量都在1到25,问将所有砝码挂到天平上并使之平衡的方案有多少个。
要使之平衡由物理知识可知力矩=0,左边重量 X 左边臂长+右边重量 X右边臂长=0,故状态一共有25*15*20=7500,设dp[i][j]为将前i个砝码挂上去平衡点为j的方案,同时注意因为这题有负数,所以将坐标轴移动到0到15000,初始化dp[0][7500]=1
Description
Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.
Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.
Input
The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights’ values.
Output
The output contains the number M representing the number of possibilities to poise the balance.
Sample Input
2 4
-2 3
3 4 5 8
Sample Output
2
代码
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
int dp[21][15002];
int main()
{
int c,g;
while (scanf("%d%d",&c,&g)!=EOF)
{
int post[21];
int weight[21];
for (int i =1 ;i<=c;i++)
scanf("%d",&post[i]);
for (int i = 1;i<=g;i++)
scanf("%d",&weight[i]);
memset(dp,0,sizeof(dp));
dp[0][7500] = 1; //将平衡点右移,使之没负数情况
for (int i = 1;i<=g;i++)
for (int j = 0;j<=15000;j++)
{
for (int k = 1;k<=c;k++)
if (j >= post[k] * weight[i])
dp[i][j]+=dp[i-1][j-post[k]*weight[i]];
}
printf("%d\n",dp[g][7500]);
}
}
上面的程序跑了94MS,尝试优化了一下变成了47MS,其实只是两个循环换了一下位置
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
int dp[21][15002];
int main()
{
int c,g;
while (scanf("%d%d",&c,&g)!=EOF)
{
int post[21];
int weight[21];
for (int i =1 ;i<=c;i++)
scanf("%d",&post[i]);
for (int i = 1;i<=g;i++)
scanf("%d",&weight[i]);
memset(dp,0,sizeof(dp));
dp[0][7500] = 1; //将平衡点右移,使之没负数情况
for (int i = 1;i<=g;i++)
for (int k = 1;k<=c;k++)
for (int j = 15000;j>=post[k]*weight[i];j--)
{
dp[i][j]+=dp[i-1][j-post[k]*weight[i]];
}
printf("%d\n",dp[g][7500]);
}
}
再看看大牛的..跑了0MS….
#include <iostream>
using namespace std;
int dp[21][20000];
int main(){
int i,j,k,C,G;
int pos[21],wight[21];
while(scanf("%d%d",&C,&G)!=EOF){
for(i=1;i<=C;i++)
scanf("%d",&pos[i]);
for(i=1;i<=G;i++)
scanf("%d",&wight[i]);
memset(dp,0,sizeof(dp));
dp[0][10000]=1;
for(i=1;i<=G;i++)
for(j=0;j<=20000;j++)
if(dp[i-1][j]){
for(k=1;k<=C;k++)
dp[i][j+pos[k]*wight[i]]+=dp[i-1][j];
}
printf("%d\n",dp[G][10000]);
}
return 0;
}