PAT(甲级)2018年冬季 1152 Google Recruitment (20分)——素数判定

1152 Google Recruitment (20分)
In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google’s hiring process by visiting this website.
在这里插入图片描述
The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921… where the 10 digits in bold are the answer to Google’s question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:
Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:
For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

题意:

2004年7月,谷歌在硅谷101号公路旁的一个巨型广告牌上发布招聘信息(如下图所示)。内容非常简单,一个URL包含在自然常数e的连续数字中发现的前10位素数。可以找到这个素数的人可以访问这个网站,进入谷歌招聘过程的下一步。

自然常数e是一个众所周知的超越数(超越数)。前几个数字是:e=2.718281828459045353602874713526624977572470936959496676272407663535475945713785251664274663932003059921。。。其中粗体的10位数字是谷歌问题的答案。

现在,您被要求解决一个更一般的问题:在任何给定的L位数字的连续数字中找到第一个K位素数。

输入规格:

每个输入文件包含一个测试用例。每种情况首先在一行中给出两个正整数:L(≤1000)和K(<10),这两个正整数分别是给定数和要找到的素数的位数。然后在下一行给出L位数字N。

输出规格:

对于每个测试用例,在一行中以N的连续数字打印第一个K位素数。如果不存在这样的数字,则输出404。注意:前导零也必须作为K位数的一部分计算。例如,在2002360023中找到4位素数就是一个解决方案。但是,不能将第一个数字2视为解决方案0002,因为前导零不在原始数字中。

代码:

在这里插入图片描述

#include<bits/stdc++.h>
using namespace std;
bool IsPrime(int num) {
	if (num <= 1)
		return false;
	int sqr = sqrt(1.0 * num);
	for (int i = 2; i < sqr; ++i) {
		if (num % i == 0)
			return false;
	}
	return true;
}
int main()
{
	int len, num;
	string s,sub;
	cin >> len >> num >> s;

	for (int i = 0; i <= len - num; i++) {
		sub = s.substr(i,num);
		int n = stoi(sub);
	    if (IsPrime(n)) {
	    cout<<setw(num)<<setfill('0')<<n<<endl;
        return 0;
	    }
   }  
	cout << 404;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

隔壁de小刘

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值