PAT(A) -- 2018.9.8秋季考试-甲级(1148) 7-1 Werewolf (20 分)

1148 Werewolf - Simple Version(20 分)
Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

player #1 said: “Player #2 is a werewolf.”;
player #2 said: “Player #3 is a human.”;
player #3 said: “Player #4 is a werewolf.”;
player #4 said: “Player #5 is a human.”; and
player #5 said: “Player #4 is a human.”.
Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liers. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were Nplayers, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liers. You are supposed to point out the werewolves.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N(5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:
If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

题意: N个玩家玩狼人杀,每个人都会说一个人是好人或者是狼,正数表示好人、负数表示狼,其中必须要注意“Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liers. ”,这句话的意思是:必有一人和一狼说假话。考试时理解为至少有一狼说谎,因此第一个样例(6分)过不了,所以考甲级之前英语的过关啊。

分析: 由于数据规模N<=100,果断就3重循环暴力求解了。第一二层循环枚举狼,第三层循环验证N个人说的话是否满足一人一狼说谎的要求。

代码如下:

#include <iostream>  
#include <cmath>  
using namespace std;

int a[105] = { 0 };
int main()
{
	int n;
	cin >> n;
	for (int i = 1; i <= n; i++)cin >> a[i];
	int f1, f2;   // f1记录狼说谎的个数,f2记录民说谎的个数
	for (int i = 1; i<n; i++)
	{
		for (int j = i + 1; j <= n; j++)
		{
			f1 = 0; f2 = 0;
			for (int k = 1; k <= n; k++)
			{
				
				int dir = abs(a[k]);
				if (k == i || k == j)   // 若是狼,计算说谎次数
				{
					if (dir == i || dir == j)
					{
						if (a[k] > 0)f1++;
					}
					else
					{
						if (a[k] < 0)f1++;
					}
				}
				else				  // 若是人,计算说谎次数
				{
					if (dir == i || dir == j)
					{
						if (a[k] > 0)f2++;
					}
					else
					{
						if (a[k] < 0)f2++;
					}
				}
			}
			if (f2 == 1 && f1 == 1)  // 关键点
			{
				cout << i << " " << j;
				return 0;
			}
		}
	}
	cout << "No Solution";
	return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值