1136 A Delayed Palindrome (20分)
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )
Given any positive integer, you are supposed to find its paired palindromic number.
Input Specification:
Each input file contains one test case which gives a positive integer no more than 1000 digits.
Output Specification:
For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:
A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.
Sample Input 1:
97152
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input 2:
196
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.
#include <iostream>
#include <algorithm>
using namespace std;
string rev(string s) {
reverse(s.begin(), s.end());
return s;
}
string add(string s1, string s2) {
string s = s1;
int carry = 0;
for (int i = s1.size() - 1; i >= 0; i--) {
s[i] = (s1[i] - '0' + s2[i] - '0' + carry) % 10 + '0';
carry = (s1[i] - '0' + s2[i] - '0' + carry) / 10;
}
if (carry > 0) s = "1" + s;
return s;
}
int main() {
string s, sum;
int n = 10;
cin >> s;
if (s == rev(s)) {
cout << s << " is a palindromic number.\n";
return 0;
}
while (n--) {
sum = add(s, rev(s));
cout << s << " + " << rev(s) << " = " << sum << endl;
if (sum == rev(sum)) {
cout << sum << " is a palindromic number.\n";
return 0;
}
s = sum;
}
cout << "Not found in 10 iterations.\n";
return 0;
}
#include <bits/stdc++.h>
using namespace std;
bool ifPalin(string a){
for(int i=0;i<a.length()/2;i++){
if(a[i]!=a[a.length()-i-1])return false;
}
return true;
}
string add(string a, string b) {
string c = a;
int carry = 0;
for (int i = a.size() - 1; i >= 0; i--) {
c[i] = (a[i] - '0' + b[i] - '0' + carry) % 10 + '0';
carry = (a[i] - '0' + b[i] - '0' + carry) / 10;
}
if (carry > 0) c = "1" + c;
return c;
}
int main(){
string a;
int k=0;
cin>>a;
while(!ifPalin(a)) {
string b("");
for(int i=0;i<a.length();i++){
b.push_back(a[a.length()-1-i]);
}
// printf("%s + %s = %s\n",a.c_str(),b.c_str(),add(a,b).c_str());
cout<<a<<" + "<<b<<" = "<<add(a,b)<<endl;
a=add(a,b);
k++;
if(k==10)break;
}
if(k<=10 && ifPalin(a)) cout<<a<<" is a palindromic number.";
else cout<<"Not found in 10 iterations.";
return 0;
}