周赛 3 【水题&&坑题】

C - 楼下水题
Crawling in process... Crawling failed Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Mob was hijacked by the mayor of the Town "TruthTown". Mayor wants Mob to count the total population of the town. Now the naive approach to this problem will be counting people one by one. But as we all know Mob is a bit lazy, so he is finding some other approach so that the time will be minimized. Suddenly he found a poll result of that town where N people were asked "How many people in this town other than yourself support the same team as you in the FIFA world CUP 2010?" Now Mob wants to know if he can find the minimum possible population of the town from this statistics. Note that no people were asked the question more than once.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with an integer N (1 ≤ N ≤ 50). The next line will contain N integers denoting the replies (0 to 106) of the people.

Output

For each case, print the case number and the minimum possible population of the town.

Sample Input

2

4

1 1 2 2

1

0

Sample Output

Case 1: 5

Case 2: 1

分析:
这道题好坑的说,意思就是 一个人想统计一个城市的人口,这个城市的人都喜欢足球,现在询问这些人,每个人都会说出除了自己之外还有几个人和他喜欢同一个球队。最后推出这个城市的最小人口。
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int pp[60];
int n;

bool cmp(int a,int b)
{
	return a<b;
}

int main()
{
	int t;
	int cnt=0;
	scanf("%d",&t);
	while(t--)
	{
		int sum,sb;
		sum=0,sb=0;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		scanf("%d",pp+i);
		sort(pp,pp+n,cmp);
		for(int i=0;i<n;i++)
		{
			if(i==0||pp[i-1]==pp[i])
			sb++;
			else
			{
			  sum+=(sb+pp[i-1])/(pp[i-1]+1)*(pp[i-1]+1);
			  sb=0;
			}
		}
		sum+=(sb+pp[n-1])/(pp[n-1]+1)*(pp[n-1]+1);
		printf("Case %d: %d\n",++cnt,sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值