uva1121 Subsequence 【二分】

Subsequence

目录(?)[+]

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input 

Many test cases will be given. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output 

For each the case the program has to print the result on separate line of the output file. If there isn't such a subsequence, print 0 on a line by itself.

Sample Input 

10 15 
5 1 3 5 10 7 4 9 2 8 
5 11 
1 2 3 4 5

Sample Output 

2 
3
分析:

n个正整数组成一个序列。给定整数S,求长度最短的连续序列,使它们的和大于或等于S

【输入格式】

输入包含多组数据。每组数据的第一行为整数nS(10<n≤100 000,S<109);第二行为n个正整数,均不超过10 000。输入结束标志为文件结束符(EOF)。

【输出格式】

对于每组数据,输出满足条件的最短序列的长度。如果不存在,输出0。

代码:
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<stack>
#include<vector>
#include<cmath>
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define O_O(x) while(x--)
using namespace std;
const int maxn=100000+100;
const int inf=0x13131313;
int pp[maxn];
int ans;
int n,S;

void input()
{
    ans=inf;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&pp[i]);
        pp[i]+=pp[i-1];
    }
}

int main()
{
    while(scanf("%d%d",&n,&S)!=EOF)
    {
        int i=1;
        input();
        for(int j=1;j<=n;j++)
        {
            if(pp[j]-pp[i-1]>=S)
            {
                while(pp[j]-pp[i-1]>=S&&i<=j)
                {
                    ans=min(ans,j-i+1);
                }
            }
        }
        if(ans==inf)
            ans=0;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值