hdoj 1068 Girls and Boys 【匈牙利算法&&二分图匹配】



Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9747    Accepted Submission(s): 4465


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
  
  
5 2
 分析:
求不能组成情侣的男女,二分图匹配减去就行了。
AC代码:
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=1010;
int tmap[N][N];
int vis[N];
int linked[N];
int n;

void init()
{
    int i,u,v,t;
    char a;
    memset(tmap,0,sizeof(tmap));
    for(i=0;i<n;i++)
    {
        cin>>u>>a>>a>>t>>a;
        while(t--)
        {
            cin>>v;
            tmap[u][v]=1;
        }
    }
}

int dfs(int u)
{
    for(int v=0;v<n;v++)
    {
        if(!vis[v]&&tmap[u][v])
        {
            vis[v]=1;
            if(!linked[v]||dfs(linked[v]))
            {
                linked[v]=u;
                return 1;
            }
        }
    }
    return 0;
}

void solve()
{
    int cnt=0;
    memset(linked,0,sizeof(linked));
    for(int i=0;i<n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i))
            cnt++;
    }
    cout<<n-cnt/2<<endl;
}

int main()
{
    while(cin>>n)
    {
        init();
        solve();
    }
    return 0;
}
还有我用链表写一直pe是什么问题,一直搞不懂。
附上代码:
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<queue>
#include<stack>
#include<vector>
#define SI(x) cin>>x
#define PI(x) cout<<x<<endl
#define O_O(x) while(x--)
#define R return
#define mem(x,y) memset(x,y,sizeof(x))
#define FOR(i,x,n) for(i=x;i<n;i++)
using namespace std;
const int N=2020;
const int maxn=1000100;
int next[N],key[N],head[N],num;
int match[maxn],vis[maxn];
int n;

void init()
{
    num=0;
    mem(head,-1);
    mem(match,-1);
}

void add(int u,int v)
{
    key[num]=v;
    next[num]=head[u];
    head[u]=num++;
}

bool dfs(int u)
{
    int temp,v;
    for(int i=head[u];i!=-1;i=next[i])
    {
        temp=key[i];
        if(!vis[temp])
        {
            vis[temp]=1;
            if(match[temp]==-1||dfs(match[temp]))
            {
                match[temp]=u;
                R true;
            }
        }
    }
    R false ;
}

void solve()
{
    int cnt=0,i;
    FOR(i,0,n)
    {
        mem(vis,0);
        if(dfs(i))
            cnt++;
    }
    PI(n-cnt/2);
}

int main()
{
    while(SI(n))
    {
        int u,v,t,i;
        char a;
        init();
        FOR(i,0,n)
        {
            cin>>u>>a>>a>>t>>a;
            O_O(t)
            {
                SI(v);
                add(u,v);
            }
        }
        solve();
    }
    R 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值