openJudge | 单词倒排 C语言

文章介绍了使用C语言编写的两种方法,分别通过结构体和二维数组实现读入英文字符串,将单词顺序反转后输出,强调了字符串处理的基本操作。
摘要由CSDN通过智能技术生成

总时间限制: 1000ms 内存限制: 65536kB

描述

编写程序,读入一行英文(只包含字母和空格,单词间以单个空格分隔),将所有单词的顺序倒排并输出,依然以单个空格分隔。

输入

输入为一个字符串(字符串长度至多为100)。

输出

输出为按要求排序后的字符串。

样例输入

I am a student

样例输出

student a am I

答案

方法一

#include <stdio.h>
typedef struct {
    char word[100];
} word;
int main() {
    char string[100], *p=string, *pWord = NULL;
    static word words[1000];
    int wordListLast = 0, wordsListLast = 0;
    gets(string);
    for(p = string; *p != 0; p++) {
        if(*p != ' ') {
            words[wordsListLast].word[wordListLast++] = *p;
        } else {
            wordsListLast++;
            wordListLast = 0;
        }
    }
    for(int i = wordsListLast; i > -1; i--) {
        for(pWord = words[i].word; *pWord != 0; pWord++) {
            printf("%c", *pWord);
        }
        if(i != 0)
            printf(" ");
    }
}

方法二

#include <stdio.h>
int main() {
    char string[100], *p=string, *pWord = NULL, words[1000][100];
    int wordListLast = 0, wordsListLast = 0;
    gets(string);
    for(p = string; *p != 0; p++) {
        if(*p != ' ') {
            words[wordsListLast][wordListLast++] = *p;
        } else {
            wordsListLast++;
            wordListLast = 0;
        }
    }
    for(int i = wordsListLast; i > -1; i--) {
        for(pWord = words[i]; *pWord != 0; pWord++) {
            printf("%c", *pWord);
        }
        if(i != 0)
            printf(" ");
    }
}

一些感想

  1. 其实,可以不用单独弄一个结构体,一个二维数组就可以了
  • 11
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Mryan2005

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值