OpenJudge | Shortest Prefixes

总时间限制: 1000ms 内存限制: 65536kB

描述

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.

An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.

输入

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

输出

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

样例输入

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

样例输出

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

思路

  1. 先创建一个字典树,然后将所有的单词插入到字典树中。
  2. 对于每一个单词,从根节点开始,如果当前节点的子节点数为1,那么就继续往下走,直到找到一个子节点数为1或者到达单词的末尾。
  3. 输出这个单词和这个单词的前缀。

参考代码

#include <bits/stdc++.h>
using namespace std;

struct node {
    unordered_map<char, node*> mp;
    int count, isEnd;
} root;

vector<pair<string,string>> res;

void abjust(string s) {
    node *p = &root;
    for(int i = 0; i < s.size(); ++i) {
        if(p->mp.find(s[i]) != p->mp.end()) {
            ++(p->count);
            p = p->mp[s[i]];
        } else {
            p->mp[s[i]] = new node();
            ++(p->count);
            p = p->mp[s[i]];
        }
    }
    p->isEnd = 1;
    p->count += 1;
}

void findShortestPrefixes(string s) {
	node *p = &root;
	int count = 0;
	for(int i = 0; i < s.size(); ++i) {
		if(p->count == 1) {
			res.push_back(make_pair(s, s.substr(0, count)));
			return;
		}
		p = p->mp[s[i]];
		++count;
	}
	res.push_back(make_pair(s, s.substr(0, count)));
}

int main() {
    string s;
	vector<string> v;
    while(cin >> s) {
		v.push_back(s);
    }
	for(auto i: v) {
		abjust(i);
	}
	for(auto i: v) {
		findShortestPrefixes(i);
	}
    for(auto i: res) {
        cout << i.first << " " << i.second << endl;
    }
}

一些想法

我当时犯了一个错误,就是想着一边创建字典树,一边查找最短前缀,这样是不行的,因为我们不知道所有的情况,会导致很多的错误。
应该考虑到先创建字典树,然后再查找最短前缀。这样就不会出现问题了。

k-shortest c是一种图算法,用于寻找图中从一个起点到一个终点的k条最短路径。该算法可以应用于许多实际问题,例如网络路由,行程规划等。 k-shortest c算法的基本原理是在每一次迭代中,从起点到终点寻找一条最短路径,并将其添加到结果集中。然后,根据路径长度对图中的边进行更新,使得之后的迭代可以找到更短的路径。这个过程会重复k次,直到找到k条最短路径为止。 该算法可以通过以下步骤实现: 1. 设置起点和终点,并初始化结果集为空。 2. 在每次迭代中,使用Dijkstra或A*等最短路径算法找到一条最短路径。 3. 将找到的最短路径添加到结果集中。 4. 更新路径中的边的权值,使得之后的迭代可以找到更短的路径。 5. 重复步骤2-4,直到找到k条最短路径为止。 k-shortest c算法的优点是能够在不遍历整个图的情况下找到多条最短路径,从而减少了计算量。它可以提供多个解决方案供选择,使得问题的解决更加灵活。 然而,k-shortest c算法也存在一些问题。首先,随着k值的增加,算法的计算复杂度也会增加,因此在实际应用中需要权衡计算资源和最优解之间的平衡。其次,算法在处理大规模图形时可能会受到内存和计算能力的限制。 在总结中,k-shortest c是一种寻找k条最短路径的图算法,适用于各种实际问题。它通过迭代找到一条条最短路径,并更新路径的边权值,以获得更多的解决方案。尽管算法存在一些限制,但它仍然是解决某些问题的有效工具。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Mryan2005

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值