csu 1110 RMQ with Shifts(线段树) 解题报告

Description

In the traditional RMQ (Range Minimum Query) problem, we have a static array A. Then for each query (L, R) (L<=R), we report the minimum value among A[L], A[L+1], …, A[R]. Note that the indices start from 1, i.e. the left-most element is A[1].
In this problem, the array A is no longer static: we need to support another operation shift(i1, i2, i3, …, ik) (i1<i2<...<ik, k>1): we do a left “circular shift” of A[i1], A[i2], …, A[ik]. 
For example, if A={6, 2, 4, 8, 5, 1, 4}, then shift(2, 4, 5, 7) yields {6, 8, 4, 5, 4, 1, 2}. After that, shift(1,2) yields {8, 6, 4, 5, 4, 1, 2}.

Input

There will be only one test case, beginning with two integers n, q (1<=n<=100,000, 1<=q<=120,000), the number of integers in array A, and the number of operations. The next line contains n positive integers not greater than 100,000, the initial elements in array A. Each of the next q lines contains an operation. Each operation is formatted as a string having no more than 30 characters, with no space characters inside. All operations are guaranteed to be valid. Warning: The dataset is large, better to use faster I/O methods.

Output

For each query, print the minimum value (rather than index) in the requested range. 

Sample Input

7 5
6 2 4 8 5 1 4
query(3,7)
shift(2,4,5,7)
query(1,4)
shift(1,2)
query(2,2)

Sample Output

1
4
6

ac代码附上:

#include <stdio.h>
#define N 101010
struct rec
{
    int l,r,v;
} t[N*5];
int n,m,a[N],p[30];
int minn(int a,int b)
{
    if(a<b) return a;
    return b;
}
void build(int root, int l, int r)
{
    t[root].l = l;
    t[root].r = r;
    if( l==r )
    {
        t[root].v = a[l];
        return ;
    }
    int mid = (l+r)/2;
    build(root*2,l,mid);
    build(root*2+1,mid+1,r);
    t[root].v = minn(t[root*2].v,t[root*2+1].v);
    //t[root].v=t[root*2].v+t[root*2+1].v;
}
void update(int root, int x)
{
    if( t[root].l == x && t[root].r == x )
    {
        t[root].v = a[x];
        return ;
    }
    int mid = (t[root].l+t[root].r)/2;
    if( mid < x ) update(root*2+1,x);
    else update(root*2,x);
    t[root].v = minn(t[root*2].v,t[root*2+1].v);
}
int getv(int root,int l,int r)
{
    if( t[root].l == l && t[root].r == r )
    {
        return t[root].v;
    }
    int mid = (t[root].l+t[root].r)/2;
    if( l>mid ) return getv(root*2+1,l,r);
    if( r<=mid) return getv(root*2,l,r);
    return minn(getv(root*2,l,mid),getv(root*2+1,mid+1,r));
}
int main()
{
    scanf("%d%d",&n,&m);
    for (int i=1; i<=n; i++)
    {
        scanf("%d",&a[i]);
    }
    scanf("\n");
    build(1,1,n);
    while(m--)
    {
        char c,c2;
        scanf("%c%c%c%c%c%c",&c,&c2,&c2,&c2,&c2,&c2);
        if( c=='q' )
        {
            int ax,bx;
            scanf("%d,%d)\n",&ax,&bx);
            printf("%d\n",getv(1,ax,bx));
        }
        else
        {
            int j = 0;
            while(scanf("%d,",&p[++j])==1);
            j--;
            scanf(")\n");
            int tt=a[p[1]];
            for ( int i=1; i<j; i++ ) a[p[i]] = a[p[i+1]];
            a[p[j]] = tt;
            for ( int i=1; i<=j; i++) update(1,p[i]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值