UVa 10129 Play on Words 欧拉回路 解题报告

Problem Description

Some of the secret doors contain a very interesting word puzzle.The team of archaeologists has to solve

it to open that doors. Because there is no other way to open thedoors, the puzzle is very important

for us.

There is a large number of magnetic plates on every door. Everyplate has one word written on

it. The plates must be arranged into a sequence in such a way thatevery word begins with the same

letter as the previous word ends. For example, the word ‘acm’ canbe followed by the word ‘motorola’.

Your task is to write a computer program that will read the listof words and determine whether it

is possible to arrange all of the plates in a sequence (accordingto the given rule) and consequently to

open the door.

Input

The input consists of T test cases. The number of them (T) isgiven on the first line of the input file.

Each test case begins with a line containing a single integernumber N that indicates the number of

plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a singleword. Each word

contains at least two and at most 1000 lowercase characters, thatmeans only letters ‘a’ through ‘z’ will

appear in the word. The same word may appear several times in thelist.

Output

Your program has to determine whether it is possible to arrangeall the plates in a sequence such that

the first letter of each word is equal to the last letter of theprevious word. All the plates from the

list must be used, each exactly once. The words mentioned severaltimes must be used that number of

times.

If there exists such an ordering of plates, your program shouldprint the sentence ‘Ordering is

possible.’. Otherwise, output the sentence ‘The door cannot beopened.

Sample Input

3

2

acm

ibm

3

acm

malform

mouse

2

ok

ok

Sample Output

The door cannot be opened.

Ordering is possible.

The door cannot be opened.


分析:首先利用okDeg()判断所有入度等于出度(由于不要求回到原点,则半欧拉图也符合条件),然后用并查集判断是否联通,当两者都满足时,则为欧拉回路。

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
using namespace std;
#define MAXN 30

int T, n, m, f[MAXN], u, v;
int in[MAXN], out[MAXN];
char str[1010];

int find(int x)
{
    return x == f[x] ? x : (f[x] = find(f[x]));
}

void merge(int x, int y)
{
    x = find(x);
    y = find(y);
    if(x != y)
        f[x] = y;
}

int okDeg()
{
    int fs = 0, fe = 0;
    for(int i = 0; i < 26; i++)
    {
        if(in[i] != out[i])
            if(in[i] + 1 == out[i] && !fs)
                fs = 1;
            else if(in[i] == out[i] + 1 && !fe)
                fe = 1;
            else return 0;
    }
    return 1;
}

int main()
{
    scanf("%d", &T);
    while(T--)
    {
        memset(in, 0, sizeof(in));
        memset(out, 0, sizeof(out));
        for(int i = 0; i < 28; i++) f[i] = i;

        scanf("%d", &n);
        for(int i = 0; i < n; i++)
        {
            scanf("%s", str);
            u = str[0] - 'a';
            v = str[strlen(str) - 1] - 'a';
            in[v] ++;
            out[u] ++;
            merge(u, v);
        }
        if(okDeg())
        {
            int sum = 0;
            for(int  i = 0; i < 26; i++)
                if(in[i] + out[i] != 0 && f[i] == i)
                    sum++;
            if(sum > 1)
                printf("The door cannot be opened.\n");
            else printf("Ordering is possible.\n");
        }
        else
            printf("The door cannot be opened.\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值