hdu 5547 Sudoku dfs 暴力回溯 解题报告

Problem Description
Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller.

Actually, Yi Sima was playing it different. First of all, he tried to generate a  4×4  board with every row contains 1 to 4, every column contains 1 to 4. Also he made sure that if we cut the board into four  2×2  pieces, every piece contains 1 to 4.

Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover.

Actually, you are seeing this because you've passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!
 

Input
The first line of the input gives the number of test cases,  T(1T100) T  test cases follow. Each test case starts with an empty line followed by 4 lines. Each line consist of 4 characters. Each character represents the number in the corresponding cell (one of '1', '2', '3', '4'). '*' represents that number was removed by Yi Sima.

It's guaranteed that there will be exactly one way to recover the board.
 

Output
For each test case, output one line containing  Case #x:, where  x  is the test case number (starting from 1). Then output 4 lines with 4 characters each. indicate the recovered board.
 

Sample Input
  
  
3 **** 2341 4123 3214 *243 *312 *421 *134 *41* **3* 2*41 4*2*
 

Sample Output
  
  
Case #1: 1432 2341 4123 3214 Case #2: 1243 4312 3421 2134 Case #3: 3412 1234 2341 4123
 

题意:横的竖的还有四个小的不能重复,有多种情况都要输出来。

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

int map[110][110];
int flag;

void dfs(int x, int y)
{
    if(x == 3 && y == 4)
    {
        for(int i = 0; i < 4; i++)
        {
            for(int j = 0; j < 4; j++)
                printf("%d", map[i][j]);
            printf("\n");
        }
        return ;
    }
    if(y == 4)
    {
        x ++;
        y = 0;
    }
    if(x > 3) return ;

    if(!map[x][y])
    {
        for(int k = 1; k <= 4; k++)
        {
            int f = 1;
            for(int i = 0; i < 4 ;i++)
            {
                if(map[x][i] == k) f = 0;
                if(map[i][y] == k) f = 0;
                if(!f) break;
            }
            if(!f) continue;
            ///处理4个小正方形,写的有点麻烦
            if(x < 2 && y < 2)
            {
                for(int i = 0; i < 2; i++)
                {
                    for(int j = 0; j < 2 ;j++)
                    {
                        if(i == x && y == j) continue;
                        if(k == map[i][j]) f = 0;
                    }
                }
            }
            else if(x >= 2 && x < 4 && y < 2)
            {
                for(int i = 2; i < 4; i++)
                {
                    for(int j = 0; j < 2 ;j++)
                    {
                        if(i == x && y == j) continue;
                        if(k == map[i][j]) f = 0;
                    }
                }
            }
            else if(x >= 2 && y >= 2)
            {
                for(int i = 2; i < 4; i++)
                {
                    for(int j = 2; j < 4 ;j++)
                    {
                        if(i == x && y == j) continue;
                        if(k == map[i][j]) f = 0;
                    }
                }
            }
            else
            {
                for(int i = 0; i < 2; i++)
                {
                    for(int j = 2; j < 4 ;j++)
                    {
                        if(i == x && y == j) continue;
                        if(k == map[i][j]) f = 0;
                    }
                }
            }
            if(f)
            {
                map[x][y] = k;
                dfs(x, y + 1);
                map[x][y] = 0;
            }
        }
    }
    else dfs(x, y + 1);
}

int main()
{
    int T;
    char s[10];
    scanf("%d", &T);
    for(int cas = 1; cas <= T; cas++)
    {
        flag = 0;
        memset(map, 0 ,sizeof(map));
        for(int i = 0; i < 4; i++)
        {
            scanf("%s", s);
            for(int j = 0; j < 4; j++)
            {
                if(s[j] != '*') map[i][j] = s[j] - '0';
            }
        }
        printf("Case #%d:\n", cas);
        dfs(0, 0);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值