欢迎使用CSDN-markdown编辑器

1115. Counting Nodes in a BST (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6


题解

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=1010;
const int INF=1000000;

struct Node{
    int left,right;
    int data;
    int level;
    Node(){
        left=right=INF;
    }
}node[maxn];

int MAXLevel=-1;

void insertBST(int root,int key,int id){
    if (key<=node[root].data)
    {
        if (node[root].left!=INF)
        {
            insertBST(node[root].left,key,id);
        }else{
            node[id].level=node[root].level+1;
            if (node[id].level>MAXLevel)
            {
                MAXLevel=node[id].level;
            }
            node[root].left=id;
        }
    }else{
        if (node[root].right!=INF)
        {
            insertBST(node[root].right,key,id);
        }else{
            node[id].level=node[root].level+1;
            if (node[id].level>MAXLevel)
            {
                MAXLevel=node[id].level;
            }
            node[root].right=id;
        }
    }
}

int main(){
    int n;
    scanf("%d",&n);
    int key;
    for (int i=0;i<n;i++)
    {
        scanf("%d",&key);
        node[i].data=key;
        if (i==0)
        {
            node[i].level=1;
        }else{
            insertBST(0,key,i);
        }
    }
    int firstAns=0,secondAns=0;
    for (int i=0;i<n;i++)
    {
        if (MAXLevel==node[i].level)
        {
            firstAns++;
        }else if (MAXLevel-1==node[i].level)
        {
            secondAns++;
        }
    }
    //特判n==1
    if (n==1)
    {
        printf("1 + 0 = 1");
    }else{
        printf("%d + %d = %d",firstAns,secondAns,firstAns+secondAns);
    }
    while(1){
        getchar();
    }
    return 0;
}

注:
1.题解采用静态构建BST的方法,减少了不必要的BFS过程
2.注意特判n==1否则第五个用例失败

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值