PAT甲级1048

1048. Find Coins (25)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

#include<cstdio>
#include<iostream>
#include<string.h>
#include<string>
#include<vector>
#include<set>
#include<algorithm>
using namespace std;
int main()
{
	int N, M;
	cin >> N >> M;
	int hashtable[1001];//这里是个坑,因为M是小于等于1000,那么当v1小于500时,若这个地方设的不是1001而是501
						//求v2则会越界,但在栈中检测不出来,会导致结果错误
	fill(hashtable, hashtable + 1001, 0);
	int coin;
	set<int> v;
	for (int i = 0; i < N; i++)
	{
		//cin >> coin;
		scanf("%d", &coin);
		v.insert(coin);
		hashtable[coin]++;
	}
	bool flag = false;
	set<int>::iterator it = v.begin();
	for (it; it != v.end(); it ++)
	{
		if (hashtable[*(it)]&&*(it)<M)
		{
			hashtable[*(it)]--;
			if (M - *(it)>=*(it)&& hashtable[M - *(it)])
			{
				flag = true;
				//cout << *(it) << " " << M - *(it) << endl;
				printf("%d %d\n", *(it), M - *(it));
				break;
			}
			else
				hashtable[*(it)]++;

		}
	}
	if (!flag)
		cout << "No Solution" << endl;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值