1081. Rational Sum (20)
Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.
Input Specification:
Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.
Output Specification:
For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.
Sample Input 1:5 2/5 4/15 1/30 -2/60 8/3Sample Output 1:
3 1/3Sample Input 2:
2 4/3 2/3Sample Output 2:
2Sample Input 3:
3 1/3 -1/6 1/8Sample Output 3:
7/24
#include<cstdio>
#include<algorithm>
typedef long long LL;
struct fraction
{
LL numerator, denumerator;
LL Integer;
fraction() :Integer(0),numerator(0),denumerator(1) {}
};
LL gcd(LL a, LL b)
{
return !b ? a : gcd(b, a%b);
}
fraction reduce(fraction f)
{
if (f.denumerator < 0)
{
f.numerator = -f.numerator;
f.denumerator = -f.denumerator;
}
if (f.numerator == 0)
{
f.denumerator = 1;
}
LL d = gcd(abs(f.numerator), f.denumerator);//注意是求绝对值的最大公约数,用d保存起来
f.denumerator /= d;
f.numerator /= d;
bool flag = false;
if (f.numerator < 0)flag = true;
if (abs(f.numerator) >= f.denumerator)
{
f.Integer = abs(f.numerator) / f.denumerator;
f.numerator = abs(f.numerator)%f.denumerator;
if (flag)
{
f.Integer = -f.Integer;
f.numerator = -f.numerator;
}
}
return f;
}
fraction add(fraction f1, fraction f2)
{
fraction f;
f.denumerator = f1.denumerator*f2.denumerator;
f.numerator = f1.numerator*f2.denumerator + f1.denumerator*f2.numerator;
f = reduce(f);
f.Integer = f.Integer + f1.Integer + f2.Integer;
return f;
}
void print(fraction f)
{
if (!f.Integer)
{
if (!f.numerator)
printf("0");
else
printf("%lld/%lld", f.numerator, f.denumerator);
}
else
{
if (!f.numerator)
printf("%lld", f.Integer);
else
printf("%lld %lld/%lld", f.Integer,f.numerator, f.denumerator);
}
}
int main()
{
int N;
scanf("%d", &N);
fraction f; fraction sum;
for (int i = 0; i < N; i++)
{
scanf("%lld/%lld", &f.numerator,&f.denumerator);
sum = add(sum, f);
}
print(sum);
return 0;
}