PAT甲级1020

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

#include<cstdio>
#include<vector>
#include<queue>
using namespace std;

struct TreeNode
{
	int data;
	TreeNode *lchild, *rchild;
};
TreeNode* createTreeByPostAndIn(int* P,int postS, int postE, int* I,int inS, int inE)
{
	if (postS > postE || inS > inE) return NULL;
	int rootindex;
	for (int k = inE; k >= inS; k--)
	{
		if (I[k] == P[postE])
		{
			rootindex = k;
			break;
		}
	}
	int numLeft = rootindex-inS;//中序中左子树节点个数
	TreeNode* root = new TreeNode;
	root->data = P[postE];
	root->lchild = createTreeByPostAndIn(P, postS, postS + numLeft - 1, I, inS, inS + numLeft - 1);
	root->rchild = createTreeByPostAndIn(P, postS+numLeft,postE-1, I, rootindex+1, inE);//注意求下标是求全局中的下标
	return root;
}
void levelorder(TreeNode*root)
{
	queue<TreeNode*> Q;
	if (root)
	{
		Q.push(root);
	}
	bool flag = false;
	while (!Q.empty())
	{
		TreeNode* tn = Q.front();
		if (!flag)
		{
			printf("%d", tn->data);
			flag = true;
		}
		else
			printf(" %d", tn->data);
		Q.pop();
		if (tn->lchild) Q.push(tn->lchild);
		if (tn->rchild) Q.push(tn->rchild);
	}
}
int main()
{
	int N;
	scanf("%d", &N);
	int *postorder = new int[N];
	int *inorder = new int[N];
	int temp;
	for (int i = 0; i < N; i++)
	{
		scanf("%d", &postorder[i]);
	}
	for (int i = 0; i < N; i++)
	{
		scanf("%d", &inorder[i]);
	}
	TreeNode*ROOT = createTreeByPostAndIn(postorder, 0, N - 1, inorder, 0, N - 1);
	levelorder(ROOT);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值