hdu 5414 CRB and String(字符串模拟)

42 篇文章 0 订阅
20 篇文章 0 订阅

CRB and String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1658    Accepted Submission(s): 539


Problem Description
CRB has two strings  s  and  t .
In each step, CRB can select arbitrary character  c  of  s  and insert any character  d  ( d  c ) just after it.
CRB wants to convert  s  to  t . But is it possible?
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case there are two strings  s  and  t , one per line.
1 ≤  T  ≤  105
1 ≤  |s|  ≤  |t|  ≤  105
All strings consist only of lowercase English letters.
The size of each input file will be less than 5MB.
 

Output
For each test case, output "Yes" if CRB can convert s to t, otherwise output "No".
 

Sample Input
  
  
4 a b cat cats do do apple aapple
 

Sample Output
  
  
No Yes Yes No
 
solution:
可以在s串任意添加字符,问能否添加至和t串相同,担忧要求,必须在某字符c后添加字符d且c!=d,对于这个特殊要求我们可以得出一个结论是s和t的首字符必须相同,且t的首字符连续的长度不能大于s的首字符连续的长度,然后对于字符s我们可以从后往前扫看是否每个字符都是按照这种顺序在t中出现,具体看代码。
tips:这道题要注意两个用例 
apl
apple
这个 是Yes,可以每次都在a后加p
aaa
abaa
这也是Yes,即s的首字符连续的长度可以大于t的首字符连续的长度
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1e5 + 200;
int num1[30], num2[30];
char s1[maxn], s2[maxn];
int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%s%s", s1, s2);
        int len1 = strlen(s1), len2 = strlen(s2);
        int x1 = 0, x2 = 0;
        while (x1<len1&&s1[x1] == s1[0])
            x1++;
        while (x2<len2&&s2[x2] == s2[0])
            x2++;
        if (x1<x2 || s1[0] != s2[0])
        {
            printf("No\n");
            continue;
        }
        x2 = len2 - 1;
        for (int i = len1 - 1; i >= 0; i--)
        {
            while (x2 >= 0 && s1[i] != s2[x2])
                x2--;
        }
        if (x2 >= 0)printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值