PAT 1130. Infix Expression (25)

1130. Infix Expression (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( <= 20 ) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by -1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

Figure 1
Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:
8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1
Sample Output 1:
(a+b)*(c*(-d))
Sample Input 2:
8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1
Sample Output 2:
(a*2.35)+(-(str%871))



通过寻找根节点的下标来划分左右子树,递归打印



#include <iostream>
#include <string>

using namespace std;

struct Node {
    string data;
    int leftChildIndex, rightChildIndex;
};

struct Node *nodes;

int rootIndex(bool *index, int n) {
    for (int i = 1; i <= n; i++) {
        if (index[i] == false) {
            return i;
        }
    }
    return -1;
}

void printTree(int rootIndex) {
    int left = nodes[rootIndex].leftChildIndex;
    if (left != -1) {
        if (nodes[left].leftChildIndex != -1) printf("(");
        printTree(nodes[rootIndex].leftChildIndex);
        if (nodes[left].leftChildIndex != -1) printf(")");
    }
    cout << nodes[rootIndex].data;
    int right = nodes[rootIndex].rightChildIndex;
    if (right != -1) {
        if (nodes[right].rightChildIndex != -1) printf("(");
        printTree(nodes[rootIndex].rightChildIndex);
        if (nodes[right].rightChildIndex != -1) printf(")");
    }
}

int main() {
    int n = 0;
    cin >> n;
    nodes = new struct Node[n + 1];
    bool *index = new bool[n + 1];
    for (int i = 1; i <= n; i++) {
        cin >> nodes[i].data >> nodes[i].leftChildIndex >> nodes[i].rightChildIndex;
        if (nodes[i].leftChildIndex != -1) index[nodes[i].leftChildIndex] = true;
        if (nodes[i].rightChildIndex != -1) index[nodes[i].rightChildIndex] = true;
    }
    int root = rootIndex(index, n);
    if (root == -1) {
        cout << "error";
    } else {
        printTree(root);
    }
    delete [] index;
    delete [] nodes;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值