CentOS 6.7安装gcc4.8.2

版权声明:需要转载的请注明出处 https://blog.csdn.net/qq_22642239/article/details/79976086
  1. 首先使用g++ --version版本,看g++的版本是否支持。

原版本是4.4.7版本不支持,但-std=c++11至少需要4.8的版本


22.CentOS中yum版本最高的是4.4.7版本,所以,需要手动安装4.8及以上的版本。这里我们安装4.8.2版本。

获取GCC 4.8.2包:

wget https://ftp.gnu.org/gnu/gcc/gcc-4.8.2/gcc-4.8.2.tar.gz


3.解压缩:

tar -xf gcc-4.8.2.tar.gz


44.进入到目录gcc-4.8.2,运行:

./contrib/download_prerequisites

这个神奇的脚本文件会帮我们下载、配置、安装依赖库,可以节约我们大量的时间和精力。

  1. 5

5.建立输出目录并到目录里:

mkdir gcc-build-4.8.2; cdgcc-build-4.8.2


  1. 6

6 ../configure --enable-checking=release--enable-languages=c,c++ --disable-multilib

--enable-languages表示你要让你的gcc支持那些语言,

--disable-multilib不生成编译为其他平台可执行代码的交叉编译器。

--disable-checking生成的编译器在编译过程中不做额外检查,也可以使用--enable-checking=xxx来增加一些检查;


7

  1.  

7编译安装(这步编译的时候需要比较长一点):

make && make install


  1. 8

8安装完成后,用gcc -v查看版本


 

参考资料详见 https://jingyan.baidu.com/article/15622f2435355dfdfcbea595.html

阅读更多 登录后自动展开
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页