05-树6. Path in a Heap

Insert a sequence of given numbers into an initially empty min-heap H. Then for any given index i, you are supposed to print the path from H[i] to the root.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (<=1000) which are the size of the input sequence, and the number of indices to be checked, respectively. Given in the next line are the N integers in [-10000, 10000] which are supposed to be inserted into an initially empty min-heap. Finally in the last line, M indices are given.

Output Specification:

For each index i in the input, print in one line the numbers visited along the path from H[i] to the root of the heap. The numbers are separated by a space, and there must be no extra space at the end of the line.
Sample Input:5 3
46 23 26 24 10
5 4 3

Sample Output:24 23 10
46 23 10
26 10

这题属于二叉堆的练手题,开始以为二叉堆很难。 。结果发现还是比AVL和CBT容易一些。coding不到半小时就AC了。 。好久没有这么痛快了。

#include<stdio.h>

int IsFull(int n,int i);
void Insert(int* p,int k,int i);

int main(){
    int m,n,i,k;
    scanf("%d%d",&m,&n);
    int heap[m+1];
    heap[0] = -20000;
//  构建heap 
    for(i = 1;i<=m;i++){
        scanf("%d",&k);
        if(1 == i)
            heap[i] = k;
        else{
            if(IsFull(m,i-1))
                break;
            else
                Insert(heap,k,i);       
        }
    }
//  读取,输出
    for(i = 0;i<n;i++){
        scanf("%d",&k);
        for(int j = k;j;j/=2){
            if(j == k)
                printf("%d",heap[j]);
            else
                printf(" %d",heap[j]);
        }
        if(i!=n-1)
            printf("\n");
    } 

    return 0;
} 

void Insert(int* p,int k,int i){
    for(;p[i/2]>k;i/=2)
        p[i] = p[i/2];
    p[i] = k;
}

int IsFull(int n,int i){
    if(n == i)
        return 1;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
import heapq import copy # 定义状态类 class State: def __init__(self, board, moves=0, parent=None, last_move=None): self.board = board self.moves = moves self.parent = parent self.last_move = last_move def __lt__(self, other): return self.moves < other.moves def __eq__(self, other): return self.board == other.board # 定义转移函数 def move(state, direction): new_board = copy.deepcopy(state.board) for i in range(len(new_board)): if 0 in new_board[i]: j = new_board[i].index(0) break if direction == "up": if i == 0: return None else: new_board[i][j], new_board[i-1][j] = new_board[i-1][j], new_board[i][j] elif direction == "down": if i == len(new_board)-1: return None else: new_board[i][j], new_board[i+1][j] = new_board[i+1][j], new_board[i][j] elif direction == "left": if j == 0: return None else: new_board[i][j], new_board[i][j-1] = new_board[i][j-1], new_board[i][j] elif direction == "right": if j == len(new_board)-1: return None else: new_board[i][j], new_board[i][j+1] = new_board[i][j+1], new_board[i][j] return State(new_board, state.moves+1, state, direction) # 定义A*算法 def astar(start, goal): heap = [] closed = set() heapq.heappush(heap, start) while heap: state = heapq.heappop(heap) if state.board == goal: path = [] while state.parent: path.append(state) state = state.parent path.append(state) return path[::-1] closed.add(state) for direction in ["up", "down", "left", "right"]: child = move(state, direction) if child is None: continue if child in closed: continue if child not in heap: heapq.heappush(heap, child) else: for i, (p, c) in enumerate(heap): if c == child and p.moves > child.moves: heap[i] = (child, child) heapq.heapify(heap) # 测试 start_board = [[1, 2, 3], [4, 5, 6], [7, 8, 0]] goal_board = [[2, 3, 6], [1, 5, 8], [4, 7, 0]] start_state = State(start_board) goal_state = State(goal_board) path = astar(start_state, goal_board) for state in path: print(state.board) 这段代码运行后报错,因为State是不可hash的,那么如何修改才能使得功能一样且能够运行
最新发布
03-27
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值