HDU 1024

Max Sum Plus Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20441 Accepted Submission(s): 6770

Problem Description
Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output
6
8

dp[i][j]为将j段数分成i段时的最大值,对于第j个数。考虑不管怎么样都取a[j]则要么a[j]和dp[i][j-1]构成一段,要么自己另开一段,则转移方程为dp[i][j] = max(dp[i][j-1],dp[i-1][k])+a[j];考虑分成i段至少需要i个数,所以i-1<=k<=j-1。然后我们找到整个dp数组的最大值就是要求的结果。
开始单纯的怕爆栈所以用了两个数组是去操作,两个数组循环利用。 。却超时了。看了下吓死了三重循环。 。看了题解后知道应该是开一个滚动数组存上一步的到j时的最大值。并且再操作过程中Max自动存的就是当前dp数组的最大值。节省代码。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
//#define LOCAL

using namespace std;
int a[1000010];
int dp[1000010];
int mmax[1000010];
int main()
{
#ifdef LOCAL
    freopen("data.in","r",stdin);
    freopen("data.out","w",stdout);
#endif // LOCAL
    int m,n;
    int Max;
    while(scanf("%d%d",&m,&n)!=EOF){
        int i,j;
        for(i = 1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(mmax,0,sizeof(mmax));
        memset(dp,0,sizeof(dp));
        for(i = 1;i<=m;i++){
            Max = -0x3f3f3f3f;
            for(j = i;j<=n;j++){
                dp[j] = max(mmax[j-1],dp[j-1]) + a[j];
                mmax[j-1] = Max;
                Max = max(Max,dp[j]);
            }
        }

        printf("%d\n",Max);

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值