N皇后问题
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13442 Accepted Submission(s): 6099
Problem Description
在N*N的方格棋盘放置了N个皇后,使得它们不相互攻击(即任意2个皇后不允许处在同一排,同一列,也不允许处在与棋盘边框成45角的斜线上。
你的任务是,对于给定的N,求出有多少种合法的放置方法。
Input
共有若干行,每行一个正整数N≤10,表示棋盘和皇后的数量;如果N=0,表示结束。
Output
共有若干行,每行一个正整数,表示对应输入行的皇后的不同放置数量。
Sample Input
1
8
5
0
Sample Output
1
92
10
只要学了编程的人大概都听过这么一个问题。 。但是能用位运算去写的就不太多。 。参考大牛博客
速度是非常快的
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n;
int tot;
int high;
void dfs(int row,int ld,int rd){
if(row == high){
tot++;
return ;
}
int pos = (~(row|ld|rd))&high;
while(pos){
int P = pos&(-pos);
pos = pos - P;
dfs(row+P,(ld+P)<<1,(rd+P)>>1);
}
}
int main()
{
while(scanf("%d",&n)&&n){
high = (1<<n)-1;
tot = 0;
dfs(0,0,0);
printf("%d\n",tot);
}
return 0;
}