POJ 3295 递归模拟

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10877 Accepted: 4129

Description

WFF ‘N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

p, q, r, s, and t are WFFs
if w is a WFF, Nw is a WFF
if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs. 

The meaning of a WFF is defined as follows:

p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below. 

Definitions of K, A, N, C, and E
w x Kwx Awx Nw Cwx Ewx
1 1 1 1 0 1 1
1 0 0 1 0 0 0
0 1 0 1 1 1 0
0 0 0 0 1 1 1

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

模拟几种逻辑运算操作,看是不是永真式。类比前缀表达式,用一个栈维护就行。这里用了系统递归的栈。用枚举位运算来操作。

#include <iostream>
#include <cstdio>

using namespace std;

char ss[250];
int sig;
int i;

int fun(){
    char c = ss[sig++];
    int k;
    if('p'<=c&&c<='t'){
        if(i&(1<<c - 'p')) k = 1;
        else k = 0;
        return  k;
    }
    switch (c){
        case 'K':
            return fun()&fun();
        case 'A':
            return fun()|fun();
        case 'N':
            return !fun();
        case 'C':
            return !fun()|fun();
        case 'E':
            return !(fun()^fun());
    }
}

int main(){
    while(scanf("%s",ss)&&ss[0]!='0'){
        int pp = 1;
        for(i = 0;i<(1<<5);i++){
            sig = 0;
            if(fun() == 0){
                pp = 0;
                break;
            }
        }
        if(pp) printf("tautology\n");
        else printf("not\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值