POJ 2057 贪心思想在动态规划中的应用

题目

The Lost House
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 2495 Accepted: 1033
Description

One day a snail climbed up to a big tree and finally came to the end of a branch. What a different feeling to look down from such a high place he had never been to before! However, he was very tired due to the long time of climbing, and fell asleep. An unbelievable thing happened when he woke up —- he found himself lying in a meadow and his house originally on his back disappeared! Immediately he realized that he fell off the branch when he was sleeping! He was sure that his house must still be on the branch he had been sleeping on. The snail began to climb the tree again, since he could not live without his house.

When reaching the first fork of the tree, he sadly found that he could not remember the route that he climbed before. In order to find his lovely house, the snail decided to go to the end of every branch. It was dangerous to walk without the protection of the house, so he wished to search the tree in the best way.

Fortunately, there lived many warm-hearted worms in the tree that could accurately tell the snail whether he had ever passed their places or not before he fell off.

Now our job is to help the snail. We pay most of our attention to two parts of the tree —- the forks of the branches and the ends of the branches, which we call them key points because key events always happen there, such as choosing a path, getting the help from a worm and arriving at the house he is searching for.

Assume all worms live at key points, and all the branches between two neighboring key points have the same distance of 1. The snail is now at the first fork of the tree.

Our purpose is to find a proper route along which he can find his house as soon as possible, through the analysis of the structure of the tree and the locations of the worms. The only restriction on the route is that he must not go down from a fork until he has reached all the ends grown from this fork.

The house may be left at the end of any branches in an equal probability. We focus on the mathematical expectation of the distance the snail has to cover before arriving his house. We wish the value to be as small as possible.

As illustrated in Figure-1, the snail is at the key point 1 and his house is at a certain point among 2, 4 and 5. A worm lives at point 3, who can tell the snail whether his house is at one of point 4 and 5 or not. Therefore, the snail can choose two strategies. He can go to point 2 first. If he cannot find the house there, he should go back to point 1, and then reaches point 4 (or 5) by point 3. If still not, he has to return point 3, then go to point 5 (or 4), where he will undoubtedly find his house. In this choice, the snail covers distances of 1, 4, 6 corresponding to the circumstances under which the house is located at point 2, 4 (or 5), 5 (or 4) respectively. So the expectation value is (1 + 4 + 6) / 3 = 11 / 3. Obviously, this strategy does not make full use of the information from the worm. If the snail goes to point 3 and gets useful information from the worm first, and then chooses to go back to point 1 then towards point 2, or go to point 4 or 5 to take his chance, the distances he covers will be 2, 3, 4 corresponding to the different locations of the house. In such a strategy, the mathematical expectation will be (2 + 3 + 4) / 3 = 3, and it is the very route along which the snail should search the tree.

Input

The input contains several sets of test data. Each set begins with a line containing one integer N, no more than 1000, which indicates the number of key points in the tree. Then follow N lines describing the N key points. For convenience, we number all the key points from 1 to N. The key point numbered with 1 is always the first fork of the tree. Other numbers may be any key points in the tree except the first fork. The i-th line in these N lines describes the key point with number i. Each line consists of one integer and one uppercase character ‘Y’ or ‘N’ separated by a single space, which represents the number of the previous key point and whether there lives a worm (‘Y’ means lives and ‘N’ means not). The previous key point means the neighboring key point in the shortest path between this key point and the key point numbered 1. In the above illustration, the previous key point of point 2 or 3 is point 1, while the previous key point of point 4 or 5 is point 3. This integer is -1 for the key point 1, means it has no previous key point. You can assume a fork has at most eight branches. The first set in the sample input describes the above illustration.

A test case of N = 0 indicates the end of input, and should not be processed.
Output

Output one line for each set of input data. The line contains one float number with exactly four digits after the decimal point, which is the mathematical expectation value.
Sample Input

5
-1 N
1 N
1 Y
3 N
3 N
10
-1 N
1 Y
1 N
2 N
2 N
2 N
3 N
3 Y
8 N
8 N
6
-1 N
1 N
1 Y
1 N
3 N
3 N
0
Sample Output

3.0000
5.0000
3.5000

题意

有一只蜗牛从一棵树上的某一个枝桠上掉了下来,因为他的壳掉在了枝桠上。他想再往上爬找到自己的壳,树上有一些虫,这些虫能告诉他他之前来过这个节点没有。假设壳子在节点上的概率相等。求蜗牛所需走路程的期望。

题解

采用DP解决,让当前节点访问下一节点时的重复步数最小。然后递推。
比较难的一题
在《浅谈贪心思想在动态规划中的应用 —– 黄劲松》 这个论文里有详细的推导和证明。

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
#include <string>
#include <set>
#include <cmath>
#include <map>
#include <queue>
#include <sstream>
#include <vector>
#include <iomanip>
#define m0(a) memset(a,0,sizeof(a))
#define mm(a) memset(a,0x3f,sizeof(a))
#define m_1(a) memset(a,-1,sizeof(a))
#define f(i,a,b) for(i = a;i<=b;i++)
#define fi(i,a,b) for(i = a;i>=b;i--)
#define lowbit(a) ((a)&(-a))
#define FFR freopen("data.in","r",stdin)
#define FFW freopen("data.out","w",stdout)
#define INF 0x3f3f3f3f
typedef long long ll;
typedef long double ld;
const ld PI = acos(-1.0);

using namespace std;
#define SIZE (1005 )

struct Po {
    int F0, F1, leaves;
};

int G[SIZE][SIZE];
int cnt[SIZE];
int worm[SIZE];
Po T[SIZE];

bool cmp(int a, int b) {
    return (T[a].F0 + 2)*T[b].leaves < (T[b].F0 + 2)*T[a].leaves;
}

void dfs(int cur) {
    if (cnt[cur] == 0) {
        T[cur].F0 = T[cur].F1 = 0;
        T[cur].leaves = 1;
        return;
    }

    int i;
    f(i, 1, cnt[cur]) {
        int k = G[cur][i];
        dfs(k);
        T[cur].leaves += T[k].leaves;
        if (worm[k]) T[k].F0 = 0;
        T[cur].F0 += T[k].F0 + 2;
    }

    sort(G[cur] + 1, G[cur] + cnt[cur] + 1, cmp);

    int sum = 0;
    f(i, 1, cnt[cur]) {
        int k = G[cur][i];
        T[cur].F1 += T[k].F1 + (sum + 1)*T[k].leaves;
        sum += T[k].F0 + 2;
    }
}

int main() {
    //ios_base::sync_with_stdio(false); cin.tie(0);
    int n;
    while (scanf("%d",&n)&&n) {
        int i;
        m0(G); m0(cnt); m0(worm); m0(T);
        f(i, 1, n) {
            int x; char c;
            scanf("%d %c", &x, &c);
            if (x != -1)
                G[x][++cnt[x]] = i;
            if (c == 'Y')
                worm[i] = 1;
        }
        dfs(1);
        double ans = (double)T[1].F1 / T[1].leaves;
        printf("%.4f\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值