学习笔记|不同VLAN之间相互通信

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/qq_22903531/article/details/83654644

上一篇整理了不同设备的配置VLAN的方法。

但是只有是相同VLAN之间才能通信。不同VLAN之间无法通信。

今天整理一下不同VLAN之间相互通信的方法。

在划分VLAN后,不同VLAN之间不能直接进行二层通信。如果要实现VLAN间通信。下面通过三种方法实现不同VLAN之间相互通信。

1、单臂路由

单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。

cisco设备配置:

SW2的配置:

//创建vlan 10 和 vlan 20:
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)# exit

//进入接口配置模式,把0/1变成trunk口(默认是access口)
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
//进入接口配置模式分别把对应的接口,加入对应的vlan:
Switch(config)#interface fastEthernet 1/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 10
Switch(config-if)#interface fastEthernet 2/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 20

R0配置。单臂路由的配置(重要)

Router(config)#inter fas 0/0
Router(config-if)#no ip address 
Router(config-if)#no shutdown    //注意:单臂路由的配置父接口一定要no shutdown
Router(config-if)#exit

Router(config)#int fas 0/0.10
Router(config-subif)#encapsulation dot1Q 10  //注意:在配置ip时一定要先封装802.1q协议
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config-subif)#no shutdown 
Router(config-subif)#int fas 0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
Router(config-subif)#no shutdown

PC0/1的配置

ip 192.168.10.10
netmask 255.255.255.0
gateway 192.168.10.1/192.168.20.1

华为设备的配置

单臂路由的配置

system-view

interface g0/0/0.11
 dot1q termination vid 11 
 ip add 192.168.10.10 24
 arp broadcast enable
 quit

interface g0/0/0.12
 dot1q termination vid 12
 ip add 192.168.20.20 24
 arp broadcast enable
 quit

 

2、使用三层交换机实现VLAN之间的通信

cisco配置

首先需要启用三层交换机上的路由功能:ip routing
 
 1//创建vlan 10  20
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#exit

//配置SVI接口ip
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#no shutdown 
Switch(config-if)#interface vlan 20
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#no shutdown 
Switch(config-if)#exit

//改变接口模式并加入vlan
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 10
Switch(config-if)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 20

PC0/PC1配置

ip 192.168.10.10
netmask 255.255.255.0
gateway 192.168.10.1/192.168.20.1

华为配置

<S1>display current-configuration 
#sysname S1
#VLAN batch 10 20
#interface VLANif2
 ip address 192.168.10.10 255.255.255.0
#interface VLANif3
 ip address 192.168.20.20 255.255.255.0
#interface GigabitEthernet0/0/1
 port link-type access
 port default VLAN 10
#interface GigabitEthernet0/0/2
 port link-type access
 port default VLAN 20

3、跨交换机实现VLAN间的通信

三层交换机的配置(SW3)

//创建vlan 10 、 20 并设置ip
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#no shutdown 
Switch(config-if)#interface vlan 20
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#no shutdown 
Switch(config-if)#exit

//设置接口模式并加入相应的vlan(注意trunk口的设置)
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#interface fastEthernet 0/1
Switch(config-if)#switchport access vlan 10
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode trunk 
Switch(config-if)#interface fastEthernet 0/2
Switch(config-if)#switchport access vlan 20

SW21的配置:

Switch(config)#vlan 10
Switch(config-vlan)#exit

Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk

Switch(config-if)#interface fastEthernet 1/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit

SW22的配置:

Switch(config)#inter fa  1/1
Switch(config-if)#switchport mode access  

Switch(config-if)#inter fa 2/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

Switch(config)#vlan 20
Switch(config-vlan)#inter fa  1/1
Switch(config-if)#switchport access vlan 20

 

展开阅读全文

没有更多推荐了,返回首页