3-1 TeX中的引号(TexQuotes, UVa 272)

3-1 TeX中的引号(TexQuotes, UVa 272)

在TeX中,左双引号是“``”,右双引号是“''”。输入一篇包含双引号的文章,你的任务是

把它转换成TeX的格式。

样例输入:

"To be or not to be," quoth the Bard, "that

is the question".

样例输出:

``To be or not to be,'' quoth the Bard, ``that

is the question''.

【分析】

本题的关键是,如何判断一个双引号是左双引号还是右双引号。使用一个标志变量q即可。

源码:

#include<stdio.h>
int main() 
{
	int c, q = 1;//设q为标志量 
	while((c = getchar()) != EOF) {
		if(c == '"') { 
			printf("%s", q ? "``" : "''"); 
			q = !q; //第1个'"'是左双引号,显然,第二个'"'是右双引号 
		}
		else printf("%c", c);
	}
	return 0;
}

原文如下:

TEX is a typesetting language developed by Donald Knuth. It takessource text together with a few typesetting instructions and produces, onehopes, a beautiful document. Beautiful documents use “ and ” to delimitquotations, rather than the mundane " which is what is provided by mostkeyboards. Keyboards typically do not have an oriented double-quote, but theydo have a left-single-quote ` and a right-single-quote '. Check your keyboardnow to locate the left-single-quote key ` (sometimes called the “backquotekey”) and the right-single-quote key ' (sometimes called the “apostrophe” orjust “quote”). Be careful not to confuse the left-single-quote ` with the“backslash” key \. TEX lets the user type two left-single-quotes `` to create aleft-double-quote “ and two right-single-quotes '' to create a right-double-quote”. Most typists, however, are accustomed to delimiting their quotations withthe un-oriented double-quote ".

If the source contained "To be or not to be," quoth thebard, "that is the question." then the typeset document produced byTEX would not contain the desired form: “To be or not to be,” quoth the bard,“that is the question.”

In order to produce the desired form, the source file must containthe sequence: ``To be or not to be,'' quoth the bard, ``that is the question.''

You are to write a program which converts text containingdouble-quote (") characters into text that is identical except thatdouble-quotes have been replaced by the two-character sequences required by TEXfor delimiting quotations with oriented double-quotes. The double-quote (")characters should be replaced appropriately by either `` if the " opens aquotation and by '' if the " closes a quotation. Notice that the questionof nested quotations does not arise: The first " must be replaced by ``,the next by '', the next by ``, the next by '', the next by ``, the next by '',and so on.

Input

Input will consist of several lines of text containing an evennumber of double-quote (") characters. Input is ended with an end-of-filecharacter.

Output

The text must be output exactly as it was input except that: • thefirst " in each pair is replaced by two ` characters: `` and • the second" in each pair is replaced by two ' characters: ''.

Sample Input

"To be or not to be," quoth the Bard, "that is thequestion". The programming contestant replied: "I must disagree. To`C' or not to `C', that is The Question!"

Sample Output

``To be or not to be,'' quoth the Bard, ``that is the question''.The programming contestant replied: ``I must disagree. To `C' or not to `C',that is The Question!''

使用“scanf("%s")”输入字符串,但它碰到空格或者TAB就会停下来。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

追梦2017

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值