hdu 5720 - Wool (线段交的长度)

Problem Description
At dawn, Venus sets a second task for Psyche.

She is to cross a river and fetch golden wool from violent sheep who graze on the other side.

The sheep are wild and tameless, so Psyche keeps on throwing sticks to keep them away. 

There are  n  sticks on the ground, the length of the  i -th stick is  ai .

If the new stick she throws forms a triangle with any two sticks on the ground, the sheep will be irritated and attack her. 

Psyche wants to throw a new stick whose length is within the interval  [L,R] . Help her calculate the number of valid sticks she can throw next time.
 

Input
The first line of input contains an integer  T   (1T10) , which denotes the number of test cases.

For each test case, the first line of input contains single integer  n,L,R   (2n105,1LR1018) .

The second line contains  n  integers, the  i -th integer denotes  ai   (1ai1018) .
 

Output
For each test case, print the number of ways to throw a stick.
 

Sample Input
  
  
2 2 1 3 1 1 4 3 10 1 1 2 4
 

Sample Output
  
  
2 5
Hint
In the first example, $ 2, 3 $ are available. In the second example, $ 6, 7, 8, 9, 10 $ are available.
 


思路: 排序,得出可笑的区间长度并,总长减去可行的,就是不可行的长度。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <bits/stdc++.h>
#include <stack>
#define LL long long

using namespace std;

#define For(i,j,n) for(int i=j;i<=n;i++)
#define mst(ss,b) memset(ss,b,sizeof(ss));

const int N=1200000;

const LL mod=998244353;

int T;
int n,m;
int len;

LL ll,rr;

LL a[1200000];
int b[1200000];
LL r[120000000];
LL l[120000000];


bool cmp(LL x,LL b)
{
    return x>b;
}

bool can(LL li,LL ri)
{
    LL t=max(li,ll);
    LL u=min(ri,rr);

    if(t>u)
        return false;
    return true;
}

bool cmp2(int x,int y)
{
    return l[x]<l[y];
}


int main()
{
    scanf("%d",&T);

    while(T--)
    {
        scanf("%d%I64d%I64d",&n,&ll,&rr);

        for(int i=0;i<n;i++)
            scanf("%I64d",&a[i]);

        sort(a,a+n,cmp);

        int cnt=0;
        for(int i=0;i<n;i++)
        {
            r[i] = a[i] + a[i+1] -1;
            l[i] = a[i] - a[i+1] +1;

            if(can(l[i],r[i]))
            {
                b[cnt++]=i
            }



        }

        sort(b,b+cnt,cmp2);

        LL low,high;
        LL ans=0;

        for(int i=0;i<cnt;i++)
        {

            int j;
            low  = l[b[i]];
            high = r[b[i]];

            for(j=i+1;j<cnt;j++)
            {
                if(l[b[j]]<=high)
                {
                    high = max(high,r[b[j]]);
                }
                else break
            }

            if(low <=ll) low=ll;
            if(high>= rr) high=rr;

            ans = ans + high - low + 1;

            i=j-1;
        }

        printf("%I64d\n",rr-ll+1 - ans);

    }

    return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值